Algorand Wallet Wont Connect to Ledger Nano X following firmware 2.0.0 update

I’ve just updated the firmware to 2.0.0 on my Ledger Nano X and cant now connect to it to authorise transactions from my Algorand Wallet on my Android phone (running Android 11). I’ve been through all the fixes provided by Ledger (reset pairing in Nano X, clearing the bluetooth cache on the phone, turning off/on). Whats pointing me to the Algorand Wallet is that I can, after a couple of attempts, connect to the Nano X after bluetooth pairing through Ledger Live ie the bluetooth connection works with that. But it won’t connect from the Algorand Wallet.

So I’m not sure if this is a Ledger issue or an Algorand Wallet issue … or a bit of both! I’d be grateful for some new ideas and help. Thanks!


Same issue, same situation.

Please see thread Help: Why can't I send crypto after reinstalling Algorand Official Wallet and recovering account? - #29 by DeFiYourLife

UPDATE: The workaround i did here was i removed the nano ledger account address from my algrand wallet and then i re-paired the nano ledger with the algorand app. Then it finally fricken worked.

same issue as well. I’m trying to participate in the Governance voting by completing the process, sending 0 algo with the attached note but nano ledger fails to connect with the app (in the past it has worked). I am also on the latest version of the nano ledger and Algo app and iphone app version.

Even when i try with myalgo web wallet i get the following error Unknown Error. Code 0x16E

Being that i am having issues on 2 seperate apps. i suspect nano ledger new patch is to blame.

Can you try Help: Why can’t I send crypto after reinstalling Algorand Official Wallet and recovering account? - #44 by fabrice?

Let’s move all comments to the above thread to have everything at the same place