AlgoSDK is not correctly working with node version "8.12.0"

I’ve used algoSDK with node version “10.16.2” it worked perfectly, but when tried with node version “8.12.0” it does not work. Is it true that is does not work with older versions of node?

What error are you getting?

I was getting, “Reserved Keyword”, after analysing I thought that it was happening because of package dependencies. But not getting it clear.