Android wallet - unable to create account

On my Android smartphone, I downloaded and installed the Algorand app. I click on Create Account, then Choose Password and Verify Password. In the Enable touch/face ID screen, the No button is inactive. I click on the Enable touch/face ID button and place my finger on Android button, screen changes to Back up this passphrase with 25 words. I send these to my email account, or write them down, then click on back arrow. I am taken back to Enable touch/face ID screen. I verify my fingerprint again, but the screen returns to Enable touch/face ID Back arrow takes me to Verify Password. I am stuck! I tried to create an account before activating fingerprint security on my Android, but the 'No button on the Enable touch/face ID screen was inactive then too. Is there a desktop wallet which will still allow me to collect rewards?

Per chance do you have a Samsung Galaxy 7 or 8? I know we ran into a problem similar to yours on a Samsung before I tried it on a newer OnePlus.

To your closing question, you collect rewards by holdings regardless of where you hold. So the My Algo wallet or others are fine. However, to ‘see’ the rewards some people recommend sending a 0 amount transaction, even to yourself, every so often but not such that the minimal transaction cost would exceed your rewards. So most places recommend once a day unless you have a very large balance.

Good luck! Cheers, -Pk

Hi there, yes, I have a Samsung SM-A520F from 2017. At least I know I am not the only one. Thanks for your help. Janet

Ah. That might indeed be it - the Samsung fingerprint system does something wonky as I find it doesn’t work with some other apps too. My banking app just vomits on the Samsung fingerprint verify for example. Cheers, -Pk

Hey guys,

This is Ian, product lead for Algorand Wallet. First of all, sorry that you’re having issues! We actually released a new version of the wallet yesterday (v4) which took care of a lot of UX and usability issues. Would you be willing to try to re-create the issue you’re having after upgrading to the newer version? I’d be interested to see if this update solved it or if you’re still having login issues.

Feel free to respond here or email me at Thanks!

So I have a Galaxy 7 Edge and I’m having the same problem - it doesn’t seem to like the fingerprint sensor or whatever API Samsung uses to make it work. I should note, if I wasn’t clear above, I have this problem with other apps that support fingerprint authentication too. Not all but some.

The rest of the update looks great! If you get a chance, using the system theme for inheriting ‘dark’ mode would be nice in the future.

And if you want to educate me in my other thread on my other questions, I’ll send you pizza. :wink:

Thanks for the great wallet though, it’s super clean and responsive. The little QR update was nice too.

Cheers, -Pk