Can't cast my vote

Hi, Algo Foundation,
I have registered for the “governance” program, using the official Android Algorand Wallet, and an account using Nano-S HW key. Now, when I try to cast my vote:

  • I open the ‘Algorand Wallet’ in Secure Folder
  • I tap ‘Get Started’ of ‘Algorand governance program is starting’
  • I cast my vote in Samsung Internet browser

Then nothing happens. I can repeat the above steps any time.
How can I cast my vote?

Did you use a Nano S or a Nano X?
The Nano S does not work with the official Algorand wallet.

What do you mean by “Secure Folder”?

Is the connection via Wallet Connect successful?

Can you give a screenshot of the last few screens you are seeing (removing all personal information)?

I ran into similar issue when trying to complete the voting on mobile devices. Later I opened the voting page on my laptop and use Wallet Connect QR code to log in with my Algorand Wallet app. With this approach the signing message modal showed up on my wallet app and I was able to send the transaction.

Hope it helps.

Dear @fabrice ,
“Secure folder” is a Knox app packaged with my phone.
The problem with the present voting: it is unable to use Algorand Wallet app in secure folder

It went like this:

  • entered my HW address into Algroand Wallet not located in secure folder
  • tapped “Get Started” within Algorand Wallet not located in secure folder
  • paired my account again, this time with Wallet App not located in secure folder
  • cast my vote. This time the Algorand Wallet was started, and a transaction (my vote) was also entered into the Algorand Wallet
  • I authorised it with my Nano-X.

It seems to me that the present process flow can’t handle Algorand Wallet located in Secure Folder.

1 Like

This method didn’t work for me, I got the governance manually last time, but since I’ve updated the firmware on my ledger it’s not working. I know I have 11 days still but is there a way to send this from a HW?

1 Like

Have you tried to follow:


Please let us know if none of the above solutions work.

I’ve unpaired and re-paried my devices, removed and readded my ledger from my algowallet and still nothing. Even trying this morning it’s the same thing. Further, I don’t have the option to add notes from ledger live. I’ve sent one transaction successfully, but it doesn’t even register. I’ve been trying for three days to simply cast my vote and at this time it looks like I will be losing out on the rewards

Is there some way to do this without using the algowallet?

I’ve done all of the above and am still unable to cast my vote. I even tried sending a vote with the information from the wallet itself

Thanks for the feedback: the team behind the wallet is working on it.

If you know how to use command line, an alternative is to use the goal command line.
It’s more advanced by I can give you the instructions if you’d like.

I’d be interested in learning the goal command line

Hey there,

Have you specifically started with “Forgetting” or “Removing” your device from your phone’s bluetooth settings? And then starting the pairing process?


yes I have and the problem still persists

You can follow steps 1-6 in Participate in Consensus from Ledger Nano S/X | Algorand Developer Portal skipping all the steps that are meant to be done “on your servers”, doing just the steps “on your personal computer”, and then send and sign:

  1. Setup Ledger Nano (most likely already done)
  2. Install the Algorand Node Software on Your Server and Your Personal Computer — sync using fast catchup: Install a node - Algorand Developer Portal
  3. (Optional) Enable Telemetry on the Server
  4. Wait until Your Server Personal Computer Is Fully Synced
  5. Generate the Participation Key and Key Registration Transaction on Your Server
  6. Connect the Ledger Nano to Your Personal Computer
    goal clerk send -a 0 -f YOUR_ADDRESS -t GULDQIEZ2CUPBSHKXRWUW7X3LCYL44AI5GGSHHOQDGKJAZ2OANZJ43S72U -n 'af/gov1:j[3,"a"]' --out vote.tx
    goal clerk sign --infile vote.tx --outfile vote.sig --signer LEDGER_ADDRESS -w NAME_OF_LEDGER_WALLET
    goal clerk rawsend -f vote.sig
    Adapt to your addresses and to the correct note field. Use with “Other Wallet” to get the exact values. YOUR_ADDRESS is the address you rekeyed, while LEDGER_ADDRESS is the address in the Ledger.
  8. Check that you voted properly on

WARNING: A previous version of this post did not include the correct note field in the goal clerk send command. In general, please always check that you voted properly on and always use the note field from

Disclaimer: Algorand makes no representations regarding the functioning or security of wallets, exchanges, or tools mentioned in the answer above, and disclaims any liability therefor. You are fully responsible for the security and the availability of your keys.

The same issue since the ledger update it’s really stressful as you can vote

I have the same issue
I can’t vote

Exactly the same problem
I can’t cast a vote either, I’m so pissed of now as I will lose my rewards
The ledger update has killed the Algorand vote
So much for vote b? I have 250000 algo commited and will get slashed 8% of my coins if I can’t vote

So happy right n0w

Hi, @wynn ! You will NOT be slashed now – maybe during the next voting period.

Please see Bluetooth pairing after Ledger Nano-X Firmware update
To summarize: it is not enough to fix bluetooth pairing issue, but additionally you must add again the account signed by the Ledger Nano device in the Algarand wallet. Hope this helps!

1 Like

Can you try Help: Why can't I send crypto after reinstalling Algorand Official Wallet and recovering account? - #44 by fabrice?

Let’s move all comments to the above thread to have everything at the same place.