Docker installation on Windows

I am trying to get sandbox set up on Windows 10. I am following the instructions on the github Readme. When I do ./sandbox up in my git bash, I get the following error which I am unable to rectify.

Can you try with this Fix issues on Windows 10 + MSYS 2 by fabrice102 · Pull Request #58 · algorand/sandbox · GitHub

You can clone in a new folder:

git clone --branch windows10-pty-fixes

Hey fabrice,
I tried using this branch and it still gave me the same error.

why dont you just use WSL for example Ubuntu in virtual environment under windows?

btw, do you have windows pro or windows home?

As @scholtz mentioned, if you can use WSL 2 with Ubuntu 20.04, it is usually simpler once you managed to install WSL 2 (which can be a bit difficult).

However, Git Bash / MSYS2 should work too.

What is your:

  • Windows 10 version: Which version of Windows operating system am I running? should be 20H2 or later
  • Docker version:
    • in Git bash: docker version should be 20.10.7 or later for Docker Engine.
    • in PowerShell: Get-ItemProperty HKLM:\Software\Microsoft\Windows\CurrentVersion\Uninstall\* | select DisplayName,DisplayVersion | where {$_.DisplayName -like "Docker*"} should be 3.5.1 or later
  • Git for Windows version: git version - must be 2.32.0 or later

I have not tested with earlier version.
I saw the issue you mentioned above with earlier versions.
My guess is that your Docker is not up to date.

I have Ubuntu 20.04. How should I proceed in that?

Are you running Ubuntu 20.04 via WSL 2 on Windows?

Can you check by copy-pasting the output of the following (in triple backquotes ``` so that it looks nicer):

  • cat /etc/lsb-release
  • bash --version
  • uname -a

Yes, I am running it on WSL 2

For us to help you, it would be very helpful for you to run the above commands.

From the screenshot you are showing, it looks like you may not be running on WSL 2.
Indeed, I think I can see the text MINGW64 at the bottom of your screenshot, which usually indicate the use of MSYS 2 / Git Bash, as opposed to WSL 2.

Oh I was initially running those commands on the git bash but I have ubuntu installed as well. Should I open sandbox on that?

It should work on Git Bash too, but only if you have the latest versions of the software as specified above.

Since you also have WSL 2, I would recommend you to try on Ubuntu 20.04 over WSL 2. This should work without any issue. You may just need to enable Docker in WSL 2 if you did not do it already.

1 Like

just do this:

cd /mnt/c
mkdir algo
cd algo
git clone
cd sandbox
./sandbox up
./sandbox goal account list

you can see the files directly from windows in c:/algo/sandbox

1 Like