Does Algorand's BSN portal still work?

I was following the tutorial here:

After I registered account in and created a project using the testnet, it gave me the address, and I generated a project key:

Then I use the command line:

curl -H "x-api-key: <I pasted my project key here>"

However, it still returned 401 with JSON:


Is this BSN portal API endpoint still working? or did I miss something here?

Investigating further with the author of the article. I have an existing account on BSN with an existing project connected to Algorand TestNet which I created when this was first published. It is working as expected.

However, I can reproduce your experience. Today, I attempted to add a second project in CA like you did. I also get the UNAUTHORIZED response when supplying the Project key in the curl header. I created a third project in HongKong PCN (same location as my functioning first project), but this also fails to connect.

I will attempt to raise the issue with BSN.

Thank you, Ryan :+1:

Sorry for the inconvenience.
The bug has been fixed.
Could you please try it again?

1 Like

Yes, I can confirm the Algorand BSN Portal is functioning as expected now.

@meowking following your testing and verification, please mark the reply @Haichao as resolved.

1 Like

yep, it works, thank you! :+1:

@Haichao @ryanRfox Another question related to this is:

I saw the bcn’s limitation is 2000 TPS = 2000 transaction per seconds. Given Algorand’s current TPS is around 1000 TPS, 2000 basically gives no limit on this endpoint. While I really love this 2000 TPS if it is true, is it a typo or supposed to be 2000 transactions per DAY?

The reason I want to confirm this is that, if it is 2000 TPS then I don’t need to worry about it when I ship my product with this endpoint, but if it is 2000 per DAY, then I need to consider more.

Thank you!

This is the limited TPS, as in requests to the node per second.
There is no daily limitation.
You are right the TPS is constraint by the Algorand blockchain TPS first and then the node limitation.

Thank you @Haichao

And I found another problem in the above BSN settings page, while the algod endpoint works now, it seems the indexer endpoint still doesn’t work:

I tried 2 endpoints here:

1, /v2/accounts/{accountid}, which returned a message : failed while searching for account … this account should exist and it returned correct json when I use’s API
2, /health, it returned {“message”: 13132977}, but this doesn’t conform with the HealthCheck result scheme here: Algorand Developer Docs , there should be other required fields returned.

I tried both the CA node and HK node endpoint, both not working, and the HK node indexer endpoint even freezes without returning anything.

Can you help check on this? Thank you.

This is probably due to an older version of indexer or postgresql version.
They are looking into this and updating the versions.
Sorry for the inconvenience.
Will let you know once it’s updated and synced up.