Help: Why can't I send crypto after reinstalling Algorand Official Wallet and recovering account? - Issues with Ledger Firmware 2.0.0 and Algorand Wallet

Re-pairing should solve the issue because of the reason mentioned here.

I connected the Nano X to my phone with a USB cable. This prompts me to open ledger live on the phone and having done so I can connect to the nano to Ledger Live via USB. With the USB connection made I tried to do a transaction in the algorand wallet, sending 0 algos within my nano backed account. However this prompts me to turn on bluetooth to do the transaction which leads back to the connection failure we are all talking about there. So it seems that a USB cable connection option isn’t available in the algorand wallet. That would have been a good feature.

Maybe the failure of this option was an obvious one - but I needed to try it.

So, I’m still unable to do anything with my ledger backed account which holds my governance commitment. The way forward options I am aware of now are:

  1. Re-pair the account with the ledger. I need to look into this in more detail so I really understand what I’m doing and what’s going on. @DeFiYourLife, did you re-pair and solve the problem?

  2. Its been suggested on reddit for governance voting that “you could connect your Ledger to (use USB cable to computer). Myalgo wallet only supports the first Algorand account on a Ledger, if your governance account is not the first then that is not an option…” I only have one account on the ledger so maybe that’ll work.

  3. Or is a fix on the way which would allow a reset of the bluetooth mac address in the wallet (if thats the issue) and so re-establish the bluetooth connection between the algowand wallet and the ledger device?

1 Like

Same issue here.

Can confirm that works with ledger

I’ve had a bit more time to think about this and I see I was getting confused by the terminology around rekeying and re-pairing; I now realise they are very different things. So I think its actually very straightforward to re-pair an account using the following steps:

  1. Remove the ledger backed account with broken bluetooth in the algorand wallet
  2. Create a new account using the green + icon and choose the option > add account > pair ledger device …
    Go through the flow to add the account and the account should be restored with working bluetooth.

Before I do it can I just check that this is correct?

Thank you! I’m pretty new to this and just trying to reduce the risk of mistakes.


The instructions work on Reddit linked to above by @DeFiYourLife - I’m back up and running. It took a while to figure out what is going on, so here’s some additional points which I learned along the way and might help complete newcomers like myself:

I got my ledger backed algo account in ledger live both on desktop and mobile by adding an algorand account and then adding the account on the nano x. This was really helpful and answered some basic but fundamental questions I had about adding accounts:

Pairing in step 5 of the instructions initially didnt work. The algorand wallet spun away trying to pair until I shut it down a few times, reset the pairings in the phone and the nano x and tried again. In the end I just let it spin and then closed the algorand wallet. I then tried to pair again in the wallet, but didnt touch the nano, and it worked. So it seems you have to try twice, just like the ledger live app (see their instructions for re-pairing ). After that the account added right away and I was up and running again.

Thank you to everyone for helping out - its much appreciated.

1 Like

Hi @rob_b ! That’s great to hear. Unfortunately, I’m still not able to do send anything. I’ve tried re-pairing and unfortunately had no luck.

I even did the following:

  1. Cleared the storage for Ledger Live, Algorand Wallet, and Bluetooth
  2. Uninstalled the Ledger Live on mobile and Algorand Wallet
  3. Reset pairings on the Ledger Device
  4. Reset the Ledger Device
  5. Reset the Ledger Live Account for Desktop
  6. Re-installed Ledger Live Mobile and Algorand Wallet
  7. Recovered my private key on the Ledger Nano X
  8. Re-installed the Algorand App on the Ledger Device via Ledger Live Desktop
  9. Reconnected the Ledger Live Mobile App to my Ledger Nano X (Successfully!)
  10. Used my recovered private key to add an account in the Algorand Wallet through the “Pair Ledger Device” feature. I was successful in adding back in my accounts to the Wallet.

After doing all that, I then attempted to send 0.000000 Algo and still get the below error message:

Connection Error: Could not connect to the Ledger device. Make sure the device is unlocked, nearby and has bluetooth enabled.

I’m at my wit’s end with Algorand Wallet. Below is my current environment setup:

  • App: Algorand Wallet from Algorand, Inc
  • Platform: Android 12
  • App Version: 4.10.7
  • Phone: Pixel 3a
  • Ledger Device: Nano X
  • Ledger Firmware: 2.0.0
  • Algorand App Ledger: 1.2.15

I’m now going to attempt the MyAlgo Wallet and see if I can at least vote in Governance.

@fabrice @ian Please do let me know if you see anything else that I should attempt to fix the error.

1 Like

@rob_b @Selgald It looks like the MyAlgo Wallet suggestion will not work. When I rekeyed my account to the Ledger Nano X, a second account is created. This account serves as the Authorizing Account (ie the account that signs the transactions on behalf of my Governance Account that I linked for voting).

For some odd reason, MyAlgo (as well as AlgoSigner) will only import one account from the Ledger device and not both. Unfortunately, the account it will import is the authorizing account and not the Governance account that was rekeyed to the Ledger device. It’s a known issue according to this Reddit post. Ridiculous.

1 Like

@ian @fabrice

If you need my wallet addresses, then please let me know and I’ll email them over to you for review.

@DeFiYourLife What a nightmare - I really feel for you. All I can think of at the moment is when you reset the pairings on your ledger device and unpaired on the phone, did you turn both off and on so that the setting change took effect? You probably did but its worth mentioning.

Can you send a 0 Algo transaction from ledger live?

As far as bluetooth is concerned, if the gitbub error diagnosis is correct (linked to above), then for some reason you still have the wrong address for the updated firmware nano stored in your algorand wallet.

What I did:
delete the ledger backed account in algorand wallet, clear the pairings on the phone and ledger device, switch off bluetooth on phone and ledger device, switch everything off. Wait for a bit. Switch it all back on again, turn on bluetooth on the phone and nano, turn on algorand app in the nano, and add the ledger backed account to the wallet you should get a request to pair and then follow it through. It might be flakey a few times but keep re-trying on the phone but dont touch the nano and eventually for me it paired and worked after a few attempts.

More generally, the engineers on algo wallet need to look at this and find a better way of accommodating and repairing a firmware change …or at least allow the wallet to operate with a USB cable connection as ledger live does.

Re the multiple accounts issue I dont know anything about that but I’ll have a look later and see if I can help.


@DeFiYourLife, if you can connect to your ledger backed algorand account in ledger live and send transactions from ledger live, can you connect your wallet to the voting page and at least vote?

@rob_b Unfortunately, I can’t connect to the account via ledger live to send a vote.

I’ve been trying to do the the pairing via phone only; however, the Algorand Wallet never seems to want to pair and continuosly spins. I do get notifications from the phone to pair as well as a notification to the Ledger Device; however, I ignore trying to pair through the Ledge device as per your instructions.

During your attempt, did you ever confirm the pair through your ledger device first, then then stopped attempting to confirm the pairing via ledger device and only use the phone? Were you able to just do the entire pairing through the phone without ever attempting or having to confirm the pairing via ledger device?

1 Like

@rob_b Also, did you ever use the Ledger Live Mobile App as mentioned in the Ledger’s pairing instructions?

@DeFiYourLife - that’s pretty strange you cant connect to ledger live. Here are some thoughts:

Ledger live on laptop. I could connect to ledger live on my laptop using a USB cable without all the hassle of bluetooth. I think ledger say you can connect by cable to your ledger device from your mobile too so you should definitely try the cable options. I added the algorand account to ledger live initially through the desktop app and then exported that to the mobile app. You’ve got to allow ledger live on the ledger device and then import the account to see it in ledger live.

I definitely did not create another algorand account though, I imported the account from the ledger device. Whether or not you can have more than 1 account - I have a feeling you can only have 1 but at the moment I couldn’t point you to where I read that. But I was super careful not to create anything new, and the workflow in ledger live desktop made it easy to see the account on the ledger device and click on that to add to ledger live.

Re pairing with the phone running ledger live mobile, I accepted the pairing inside ledger live on the phone and on the ledger device. You then have to ignore the “cant connect” message as per ledger’s instructions on re-pairing and then try to connect again. It connected with bluetooth on the second attempt and I could send a 0 algo transaction.

Once I got that far and I could send 0 algo transactions and update my rewards, I relaxed a bit and realised the way to get the algorand wallet working again was to remove the ledger backed account from the wallet and then add it back in and so establishing all the correct settings for the account under the hood in the wallet.

To do that I reverted to the steps in reddit and finally got the algorand wallet to connect again. This wasn’t straightforward as I outline above, even thought algorand wallet was spinning away I noticed in bluetooth in my phone that pairing had been established ( I did accept the pairing on the phone and ledger device inside the algorand wallet) and the ledger device was in the phone’s list of paired devices. So I reasoned that the pairing was OK, but it was the bluetooth that was flakey, so I shut down the wallet, reopened it and tried to connect and eventually it did. So if you see the pairing is established in your phone just keep retrying and hopefully it will connect and let you add the account.

Re voting, I think you do need a wallet that allows notes, but the vote itself is carried out on the web app, so if you get any of the above working have a go at connecting your account to the web app and try voting.


Hi @rob_b!

Ledger Live Desktop. I imported the Algorand Accounts from my Ledger device into Ledger Live via USB. It imported the Authorizing Account that’s attached to my Governance Account, but not the Governance Account itself so that didn’t work.

Re-pairing the phone and Ledger Live Mobile. I believe I messed up on a step during the repair and going to try this again. I’ll give you an update on what happens.

If this doesn’t work, then I’m going to try an iPhone to see if it has something to do with Android.

Hi @rob_b!

Re-pairing the phone and Live Mobile (Cont.). Unfortunately, it’s still not working. As before, I was successful in recovering my account by my Ledger device, but still get the same error and can’t sign any transactions:

Connection Error: Could not connect to the Ledger device. Make sure the device is unlocked, nearby and has bluetooth enabled.

@rob_b Did you originally create your Algorand account in Ledger Live, then imported that account into the Algorand Wallet using the Ledger Nano X?

If so, then maybe that’s why I’m not able to sign Algo with the Ledger Nano X. I originally created an account within the Official Algorand Wallet and rekeyed that account using a Ledger Nano X.

My suspicion is that this error only affects rekeyed accounts from users who have updated the Ledger Nano X firmware to 2.0.0. In this scenario, users can repair their Ledger Nano X and recover their accounts via Ledger, but can’t successfully sign any Algo.

@fabrice @ian Have either of you considered that?

1 Like

Hi @DeFiYourLife to set up my nano X with the algorand wallet I set up the 24 word mnemonic and pin, installed the algorand app on the nano using Ledger Live and then linked to this from within the algorand wallet. It was a while ago so I cant quite recall all the steps but I broadly followed the instructions to set up a ledger backed account form within the algorand wallet.

I dont know anything about rekeying accounts - mine is plain vanilla, 1 account on the nano X corresponding to 1 account in the wallet. I’ve never rekeyed.

Hi @fabrice, a small point which may help in evidence gathering for your engineers. Although I have done the firmware upgrade and successfully re-paired my phone and its algorand wallet ledger backed account, the connection doesnt work as smoothly as it did before the firmware update. ie 1st time as it used to. I always have to try to do a transaction (sending 0 algos to bring in rewards) at least twice, sometimes more, before it asks me to authorise the transaction and then completes.



@fabrice @ian @rob_b

Good & Exciting News
I was able to send Algo in the Algorand Wallet and voted in Governance by using an iPhone instead of my Android phone.

What is the issue?
It’s something with the Android version of the Algorand Wallet that’s the problem. Every time I used the Algorand Wallet on an Android phone and attempted to “Preview and sign with Ledger”, I would get the below error message even after successfully re-pairing the Ledger Nano X to Ledger Live:

Connection Error: Could not connect to the Ledger device. Make sure the device is unlocked, nearby and has bluetooth enabled.

I’m not sure why. I think it has something to do with me having a re-keyed account attached to my Ledger Nano X, which causes something to break in the wallet. I only say this because the only difference (besides the phone) between @rob_b (who was successful in signing transactions on his Android) and my account is that I have a re-keyed account in my wallet and he doesn’t. @rob_b Would you provide the below specs of what you have?

  • App: Algorand Wallet from Algorand, Inc
  • App OS: Android
  • Algorand Wallet App Version: ?
  • Phone: ?
  • Ledger Device: Nano X
  • Ledger Firmware: 2.0.0
  • Algorand App Ledger: ?


  • I tested two Android Devices and neither were successful in sending Algo. Below are the details of both Android Devices that I used as well as the iPhone (which was successful in sending Algo)
  • I was able to successfully re-pair my Ledger Nano X to Ledger Live on both Androids and iPhone
  • After re-pairing, added accounts successfully using “Pair Ledger Account” feature in Android and iPhone Devices
  • Initial Algorand account was created within the Algorand Wallet and then re-keyed to a Ledger Nano X
  • Created an Algorand Account within Ledger Live, added that account to Algorand Wallet and still got the same error.
  • When attempting to re-key a ledger account to the same ledger, I would still get the same error message. Below is an image of when I attempted to re-key the account made in Ledger Live to the same Nano X device.

Android Device 1 (My Device) Specs:

  • App: Algorand Wallet from Algorand, Inc
  • Platform: Android 12
  • App Version: 4.10.7
  • Phone: Pixel 3a
  • Ledger Device: Nano X
  • Ledger Firmware: 2.0.0
  • Algorand App Ledger: 1.2.15

Android Device 2 Specs

  • App: Algorand Wallet from Algorand, Inc
  • Platform: Android 10
  • App Version: 4.10.7
  • Phone: Samsung Galaxy Note 9 (SM-N960U)
  • Ledger Device: Nano X
  • Ledger Firmware: 2.0.0
  • Algorand App Ledger: 1.2.15

iPhone Specs

  • App: Algorand Wallet from Algorand, LLC
  • Platform: iOS 14.8
  • App Version: 4.10.5
  • Phone: iPhone 12
  • Ledger Device: Nano X
  • Ledger Firmware: 2.0.0
  • Algorand App Ledger: 1.2.15
1 Like

Hi, @DeFiYourLife ,

  • first try to reset Bluetooth pairing,
  • then add the account again into the Algorand wallet

Please see the steps to follow here: Bluetooth pairing after Ledger Nano-X Firmware update

Hope this helps!

1 Like

Hi @DeFiYourLife thats excellent news and a great find! Well done. In answer to your question about my specs, they are:

  • App: Android version of official Algorand Wallet from Algorand, Inc ver 4.10.7
  • App OS: Android 11
  • Phone: Samsung A40
  • Ledger Device: Nano X
  • Ledger Firmware: 2.0.0
  • Algorand App on Ledger Nano X: 1.2.15

I can also report that:

  • I have never rekeyed any accounts. I have 3 accounts in the algorand wallet, one of which is ledger backed and which stores my governance committed algos. So that corresponds with your finding about rekeyed accounts being problematic.
  • Removing the ledger backed account and re-pairing following the reddit instructions worked.
  • Although I can connect to the nano X with bluetooth, send 0 algo transactions and have now voted, the bluetooth connection/transaction authorisation journey for sending algos from the ledger backed account does not happen reliably/the first time as it used to do before the firmware update. It always needs at least 2 attempts.
1 Like