Help: Why can't I send crypto after reinstalling Algorand Official Wallet and recovering account? - Issues with Ledger Firmware 2.0.0 and Algorand Wallet

Hi @DeFiYourLife to set up my nano X with the algorand wallet I set up the 24 word mnemonic and pin, installed the algorand app on the nano using Ledger Live and then linked to this from within the algorand wallet. It was a while ago so I cant quite recall all the steps but I broadly followed the instructions to set up a ledger backed account form within the algorand wallet.

I dont know anything about rekeying accounts - mine is plain vanilla, 1 account on the nano X corresponding to 1 account in the wallet. I’ve never rekeyed.

Hi @fabrice, a small point which may help in evidence gathering for your engineers. Although I have done the firmware 2.0.0.0 upgrade and successfully re-paired my phone and its algorand wallet ledger backed account, the connection doesnt work as smoothly as it did before the firmware update. ie 1st time as it used to. I always have to try to do a transaction (sending 0 algos to bring in rewards) at least twice, sometimes more, before it asks me to authorise the transaction and then completes.

Thanks!

2 Likes

@fabrice @ian @rob_b

Good & Exciting News
I was able to send Algo in the Algorand Wallet and voted in Governance by using an iPhone instead of my Android phone.

What is the issue?
It’s something with the Android version of the Algorand Wallet that’s the problem. Every time I used the Algorand Wallet on an Android phone and attempted to “Preview and sign with Ledger”, I would get the below error message even after successfully re-pairing the Ledger Nano X to Ledger Live:

Connection Error: Could not connect to the Ledger device. Make sure the device is unlocked, nearby and has bluetooth enabled.

I’m not sure why. I think it has something to do with me having a re-keyed account attached to my Ledger Nano X, which causes something to break in the wallet. I only say this because the only difference (besides the phone) between @rob_b (who was successful in signing transactions on his Android) and my account is that I have a re-keyed account in my wallet and he doesn’t. @rob_b Would you provide the below specs of what you have?

  • App: Algorand Wallet from Algorand, Inc
  • App OS: Android
  • Algorand Wallet App Version: ?
  • Phone: ?
  • Ledger Device: Nano X
  • Ledger Firmware: 2.0.0
  • Algorand App Ledger: ?

NOTES:

  • I tested two Android Devices and neither were successful in sending Algo. Below are the details of both Android Devices that I used as well as the iPhone (which was successful in sending Algo)
  • I was able to successfully re-pair my Ledger Nano X to Ledger Live on both Androids and iPhone
  • After re-pairing, added accounts successfully using “Pair Ledger Account” feature in Android and iPhone Devices
  • Initial Algorand account was created within the Algorand Wallet and then re-keyed to a Ledger Nano X
  • Created an Algorand Account within Ledger Live, added that account to Algorand Wallet and still got the same error.
  • When attempting to re-key a ledger account to the same ledger, I would still get the same error message. Below is an image of when I attempted to re-key the account made in Ledger Live to the same Nano X device.

DEVICE SPECS
Android Device 1 (My Device) Specs:

  • App: Algorand Wallet from Algorand, Inc
  • Platform: Android 12
  • App Version: 4.10.7
  • Phone: Pixel 3a
  • Ledger Device: Nano X
  • Ledger Firmware: 2.0.0
  • Algorand App Ledger: 1.2.15

Android Device 2 Specs

  • App: Algorand Wallet from Algorand, Inc
  • Platform: Android 10
  • App Version: 4.10.7
  • Phone: Samsung Galaxy Note 9 (SM-N960U)
  • Ledger Device: Nano X
  • Ledger Firmware: 2.0.0
  • Algorand App Ledger: 1.2.15

iPhone Specs

  • App: Algorand Wallet from Algorand, LLC
  • Platform: iOS 14.8
  • App Version: 4.10.5
  • Phone: iPhone 12
  • Ledger Device: Nano X
  • Ledger Firmware: 2.0.0
  • Algorand App Ledger: 1.2.15
1 Like

Hi, @DeFiYourLife ,

  • first try to reset Bluetooth pairing,
  • then add the account again into the Algorand wallet

Please see the steps to follow here: Bluetooth pairing after Ledger Nano-X Firmware update

Hope this helps!

1 Like

Hi @DeFiYourLife thats excellent news and a great find! Well done. In answer to your question about my specs, they are:

  • App: Android version of official Algorand Wallet from Algorand, Inc ver 4.10.7
  • App OS: Android 11
  • Phone: Samsung A40
  • Ledger Device: Nano X
  • Ledger Firmware: 2.0.0
  • Algorand App on Ledger Nano X: 1.2.15

I can also report that:

  • I have never rekeyed any accounts. I have 3 accounts in the algorand wallet, one of which is ledger backed and which stores my governance committed algos. So that corresponds with your finding about rekeyed accounts being problematic.
  • Removing the ledger backed account and re-pairing following the reddit instructions worked.
  • Although I can connect to the nano X with bluetooth, send 0 algo transactions and have now voted, the bluetooth connection/transaction authorisation journey for sending algos from the ledger backed account does not happen reliably/the first time as it used to do before the firmware update. It always needs at least 2 attempts.
1 Like

@DeFiYourLife

Can you try the following steps (this is on iOS, Android might be slightly different):

  1. (Ledger) Restart the Ledger Nano X
  2. (Ledger) Forget the Ledger Nano X from the Bluetooth menu from your phone. See Step 3 in https://support.ledger.com/hc/en-us/articles/360025864773?support=true.
  3. (Phone) Open the Algorand Wallet
  4. (Phone) Click on the + button, then Add Account, then Pair Ledger Device.
  5. (Ledger) Be sure your Ledger Nano is open. VERY IMPORTANTLY, do NOT open the Algorand app from Ledger Nano. (Despite the fact that the screen tells you so.) You must be on the screen with all the apps on Ledger Nano.
  6. (Phone) Click on Search for Ledger, and then Connect next to your Ledger. If your Ledger does not appear, restart the phone and the Nano.
  7. (Phone & Ledger) Both the phone and the Nano should display a pairing code. Confirm they are identical. Confirm on Ledger Nano. And click Pair on the phone.
  8. (Phone) The Phone will display an error telling you to open the Algorand App.
  9. (Ledger) Only now, and not before, open the Algorand App on the Ledger Nano.
  10. (Phone) Click on Connect again.
  11. (Phone) You will see the screen to recover the wallets.

After that, it worked on my iPhone.

Importantly, do NOT pair the Ledger with Ledger Live on your phone, nor with any other method.
If something gets stuck at any point, just restart the Ledger Nano and the phone.

One common issue is the following: if the first pairing is done with the Algorand app on the Ledger Nano opened, then it seems to get stuck.

@fabrice I’ve just had a final response from Ledger support to my ticket for this issue opened on the October 26th. Even though they muddle the wallet I am using (I’ve never used MyAlgoWallet), it kicks the ball back to you - no mea culpa on their side. It reads:

Prinjal (Ledger Support)
Nov 4, 2021, 14:27 GMT+1

Hello Rob,

Thank you for reaching out to Ledger Support. My name is Prinjal and I’d be happy to assist you with your request.

I am sorry but the issue is not related to Ledger device but the Algorand wallet. I would suggest reaching out to [MyAlgo wallet Support] directly with all the details as they will guide you correctly towards resolving the issue.

I hope this answers your request. Please let me know if you have any further questions.

Warm regards,

Prinjal

Ledger Support

1 Like

Ok I fixed the problem
You to repair your algo wallet with ledger as as well
As re booting the Bluetooth connection

I voted yay

1 Like

Hi @fabrice

I attempted your instructions and was able add my Ledger accounts through Pair Ledger Device. However, I still can’t send any Algo.

Every time, I attempt to preview and sign with ledger, I get the below error:

Connection Error
Having Ledger Nano X connection issues?

If so, please remove the device from your phone’s bluetooth settings, remove the ledger account, and then re-pair your Ledger following the Algorand Wallet instructions.

Specs

  • App: Algorand Wallet from Algorand, Inc
  • Platform: Android 12
  • App Version: 4.10.8
  • Phone: Pixel 3a
  • Ledger Device: Nano X
  • Ledger Firmware: 2.0.0
  • Algorand App Ledger: 1.2.15

Hi, @DeFiYourLife ,
can you write down PLEASE in a little more detail, what have you done exactly?

  • Is your Ledger Live is functional with Nano-X and BlueTooth?
  • Have you added again your account in Algorand Wallet with “Add Account | Pair Ledger Device”?

Hi @Maugli @fabrice

Yes I sure can; however, I just tried something different today and going to repeat those steps. After I did this method, I haven’t been able to successfully add my accounts to my Ledger device.

On my Android, I have both a personal profile and a work profile, and realized that I need to clear the Bluetooth cache from both.

  1. Currently, I don’t have Ledger Live on my android. My 3 ledger accounts are are also not on my Algorand Wallet.

  2. (Ledger) Reset Bluetooth pairings on Nano X. Screenshots below.

  3. (Ledger) Shutoff Bluetooth on Nano X and powered down the device.

  4. (Phone) Forgot/removed the Nano X (called Governance) from my Android.

  5. (Phone) Cleared Bluetooth Cache on my Android across my Personal and Work Profile.

  6. (Phone) Shutoff Bluetooth and powered down my Android for at least 5 minutes.

  7. (Ledger) (Phone) Powered on my Nano X and Android

  8. (Ledger) (Phone) Put the Bluetooth back on for both my Nano X and Ledger.

  9. (Phone) Opened Algorand Wallet on Android

  10. (Phone) Clicked + > Add Account > Pair Ledger Device > Searched for Ledger

  11. (Phone) Found my Nano X (called Governance) and clicked connect. Instructions popped up telling me not to open the app on Nano X, which I didn’t. I then pressed OK and the app continued to “Connecting to Ledger…”.

  12. (Ledger) (Phone) Nano X and Android requested to be paired, which I did. After pairing the devices, an error popped up:

Error!
Please open the Algorand App in your ledger device.

  1. (Ledger) From there, I opened the Algorand App on the Nano X and then attempted to connect again.
  2. (Phone) As it was attempting to “Connecting to ledger…” another error message came up:

Error!
Could not connect to the Ledger device. Make sure the device is unlocked, nearby and has bluetooth enabled

  1. (Phone) App froze on “Connecting to Ledger…” and I shut off the app. I then repeated steps 10-15 with no luck.
  2. A visual of steps 11 - 16:

1 Like

Hi, @DeFiYourLife ,

thanks for the detailed report of the steps executed.
I have repeated your steps:

  • Samsung Galaxy J7: I cleared the paired Nano device, like you
  • Nano-X: I have reset pairing, like you
  • Nano-X: switch off, switch on, like you
  • Samsung Galaxy J7: Algorand Wallet
    • Add Account
    • Pair Ledger Device
    • Search for Ledger
    • Connect (to Nano)
    • Pairing Ledger with your device: OK

After that I got the following error: “Please open the Algorand App on your ledger device”.
I opened the Algorand app on Ledger Nano-X, then cliked “Connect” again.
I got the error messages: “Could not connect to the Ledger device.” “We were unable to receive the public key of your ledger device.”
The Algorand Wallet app got into an infinite loop.

I quit the Algorand Wallet app, then started it again:

  • Samsung Galaxy J7: Algorand Wallet: Add Account
    • Add Account
    • Pair Ledger Device
    • Search for Ledger
    • Connect (to Nano) => 1 Account found
    • Verify selected account

Then I tried to send 0.0 Algo from the added account to the added account

  • Preview and sign with ledger => I got error: “Transmission error: we were unable to receive the public key of your ledger device. Please try again.”

Then I tried again to send 0.0 Algo from the added account to the added account

  • Preview and Sign with ledger
  • Ledger Approval
  • Send Algos

To summarize:

  • Issue 1: During pairing the mobile phone with the Nano-X, the issue can be reproduced: you must start in the Ledger Manager on Nano-X to pair the device, then you get an error message: “Please open the Algorand App on your ledger device”, you open the Algorand app on Nano-X and click “Connect” again, and then you get " “Could not connect to the Ledger device.” “We were unable to receive the public key of your ledger device.”

  • However, when you try again, the second time you can verify the address and add the new account to the wallet

  • Issue 2: during send, sometimes you get “Transmission error: we were unable to receive the public key of your ledger device. Please try again.”

Dear @DeFiYourLife , please try to connect again, and write down your experiences (success or failure)

Dear @ian , please investigate the above issues, as I have a feeling that the Algorand Wallet with Nano-X that the app is not too stable, sometimes gives spurious error messages. Maybe it is just a trivial step missing, like you should quit the app after pairing with the Ledger Nano-X. Thank you.

1 Like

Same issues as everyone else. I follow all the steps, I pair. I add my account. That is it. That is when the wallet stops talking to th ledger. Nothing can be done beyond that point.

I’ve gone through the pair unpair process at least 20 times. The result is always the same. No transactions can be made.The wallet will not see the ledger even 10 seconds after pairing successfully.

It pairs. It breaks.

2 Likes

Thank you very much for the feedback. We are sorry for the inconvenience and are investigating the source of the issue.

If you are not using rekeying nor multiple accounts, you may consider using MyAlgoWallet (https://wallet.myalgo.com) instead.

This should recover the same account as the official Algorand Wallet. See question on Ledger on https://algorand.foundation/gov-faq 5.

Disclaimer: Algorand makes no representations regarding the functioning or security of wallets, exchanges, or tools mentioned in the answer above, and disclaims any liability therefor. You are fully responsible for the security and the availability of your keys.

Thanks for the response. Yes, in the end I used myalgo wallet to make the needed exchanges. I also had to use myalgo wallet for governance. Unfortunately for my flight yesterday, I only had a mobile option and thus spent that entire time attempting to execute a single transaction. With myalgo wallet having no mobile ledger option and the official wallet not working with ledger, I was unable to make the transaction in time it needed to be made.

I think it is important that there be a way to make secure mobile transactions with ledger and algorand.

Having the same issue as above and unable to sign transaction. Also unable to connect second ledger backed algorand to ledger live.

No issues before using Yiedly staking. I originally had one address on the official algorand app but decided to create a second so that my governance amounts wouldnt be affected. Created a second account and it was backed by the same ledger. Tried to opt in so that I could stake however was having difficulty and was unable to get it to work. From a few google searches apparently ledger is unable to sign multi transactions and it caused an error. Unable to opt out and not entering seed phrase on webpage in order to do so.

Later updated to firmware 2.0.0 - Second account still stuck and unable to connect to ledger live (mobile and desktop)

I have other accounts I use for ASA’s that are not connected to my ledger so have been using those.
Tried to sign a transaction from the original ledger backed account today and was unable to. I repaired the bluetooth settings as instructed on ledger’s website as well as instructions on this thread. Now i am greeted with connection error when trying to sign algorand transaction.

I am not sure what is going on and it’s extremely frustrating - As it’s my governance account with the most algorand in, i’m not expecting to move it any time soon however its unnerving to know i cant access. I cant be certain but i think trying to opt in to a staking pool on yieldly with an account backed by my ledger is the root cause of this. The only problem is there isn’t a quick and safe method of reversing it.

Any help will be greatly appreciated.

  • App: Official Algorand Wallet
  • Platform: Android 11
  • App Version: 4.10.8
  • Phone: Samsung S21 Ultra-
  • Ledger Device: Nano X
  • Ledger Firmware: 2.0.0
  • Algorand App Ledger: 1.2.15
1 Like

@Sylux If you can find an iPhone from someone that you trust, then add your account there. The ledger device doesn’t seem to have any issues with connecting to an iPhone. I did that to just vote in governance. Once I was done, then I removed my account from the iPhone.

@DeFiYourLife Hi, thanks that may help someone else who stumbles upon this thread like I did.

I have already voted in this governance period. I voted before updating the firmware on my ledger. Was having issues with the second account after the yiedly opt in debacle and didn’t want to risk something going wrong with my vote!!

1 Like

Yes, there was an Algorand Wallet update, to v 4.10.9. You can see in Github that the changes were centered around the bluethooth ledger device… Android 4.10.9 · algorand/algorand-wallet@78bcc87 · GitHub
Probably that was the reason behind your success!

1 Like

@Maugli Great! Glad it’s fixed :slight_smile: