Synchronize sandbox data when switched to new computer

I was using Algorand Sandbox in my old computer and I have created too many accounts there. Now I have changed my computer to a new one and I installed Sandbox to it. Now, when I want to do transactions, I receive errors. But when I use my old computer’s sandbox, it works perfectly. How can I synchronize all data? So that, I will not have these kind of problems in the future when I change my computer.

What kind of errors do you see?

There are two parts of moving sandbox:

  • syncing to the actual network: this should not be an issue
  • copying the accounts from kmd from one sandbox to the other: you can export them using goal account export, but it’s one by one. If you use kmd with multiple accounts, best is to create a fresh new wallet goal wallet new and then you can recover all the accounts of the wallet (more precisely those created via goal account new) using goal wallet new -r

Even though I have enough algos, I see the following error.

send: failed to send transaction: %w HTTP 400 Bad Request: TransactionPool.Remember: transaction Z44MCMADT5VP3UKPYLYOKIYBDXLUJLZJ336JTOBFXFNPICZX62GQ: overspend (account 2E5QX57FMQTVQDHVMOQLASVQEZRKKA7URKRFLTEDRKI55CLF36ZVCBCXFA, data {_struct:{} Status:Offline MicroAlgos:{Raw:0} RewardsBase:0 RewardedMicroAlgos:{Raw:0} VoteID:[0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0] SelectionID:[0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0] VoteFirstValid:0 VoteLastValid:0 VoteKeyDilution:0 AssetParams:map Assets:map AuthAddr:AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAY5HFKQ AppLocalStates:map AppParams:map TotalAppSchema:{_struct:{} NumUint:0 NumByteSlice:0} TotalExtraAppPages:0}, tried to spend {1000})

When I switched back to my old computer, everything works without any problem.

There are two options:

  1. Sandbox is not synced. Run ./sandbox status, check that the last block matches the current block on
  2. Sandbox is synced on the wrong network.

In both cases, write down inside triple backquotes ```, the ouput of ./sandbox status.

I have solved the problem by moving genesis.json file from my old computer to the new computer.