Algo-DID network unreachable

Hi, I’m working in a virtual machine, created with VirtualBox,I’m using Ubuntu 22.04 as OS, and I wanted to use a CLI-based application to manage decentralized identifiers.
So, I cloned the algo-did repository, by means the link:

Then, I followed, and I ran all commands, but each one that try to connect to network failed, like for example:

algoid wallet info sample-account

which generate the error:

2023-11-02T10:35:05+01:00 ERR rpc error: code = DeadlineExceeded desc = Get “https://”: dial tcp i/o timeout

(eliminate the space between “https://” and “algo”)

I tried both version 0.1.0, present in the Git main, and version 0.5.0, which should also implement the UI.
I downloaded the two installation packages and the source code of version 0.5.0 from the link:

In version 0.5.0, the algoid ui command gave me the error Method Not Allowed.
In my opinion the problem is that it is not possible to reach the client node defined by the link:

But I don’t know what I should do, does anyone know any solution or alternative node to connect to?

Thanks you.