Consensus Participation

I have a participation node set up on my Windows 10 pro desktop. I used the installer from Randlabs github page. The node installed fine, fastcatchup to sync with the network went well and I was able to create a participation key. I am interacting with the node via command line tools.

I am having trouble registering the partkey online. When I run the goal account changeonlinestatus it throws the error that “txn validity period (14676300 to 17676300) is greater than protocol max txn lifetime 1000” Algorand dev docs recommends 3 million rounds, which is where i set the limits from.

Okay so I need to delete that partkey. When I run erase it states “the process cannot access the file because it is being used by another process” I tried RD as well, which returns the same error.

I don’t want to create a new partkey until I can delete the old one as I understand it is bad network behavior to have one address with multiple partkeys.

Can anyone help me resolve this?

There are two validity periods:

  • validity period of the part key: goal account addpartkey .... This should be 3M.
  • validity period of the transaction that register the part key: goal account changeonlinestatus .... This should be like any transaction: at most 1000 rounds. Furthermore:
    • it should be so that the current round is within the validity period
    • it should be so that the first round is after the beginning of the validity of the part key itself
    • simplest solution is just to not specify the first valid / last valid rounds on this command (if you’re able to sign within 1000 rounds)

To delete the part key, stop the node first.

Thank you for the response. I was able to delete the old partkey by stopping the node first. I’ve taken my node offline temporarily and switched to the testnet to become more familiar with proper interaction.