Ledger Does Not Have Entry?


I recently migrated my dApp from private network to test net, but when I run my application with the required modifications for test net migration, I get an error “Ledger does not have entry” when I use the Python SDK algod process to search for transactions by address.

However, I checked that the specific address has been created and I checked to see if my local node is fully synced - both answers are yes. The only thing I was thinking is that during the lifecycle of my Dapp, I expect my account address to have 0 transactions when the app is first opened, so I wonder if that would be a reason for the error.

Is the node you are using setup as an Indexer and Archival? If not, you’ll have to jump through some hoops to get at specific transactions.

I believe so; I had to manually copy the config.json file from main net directory into my newly created test net directory. Within the config.json file I see “Archival”: true, and “isIndexerActive”: true, and I’ll say that I did indeed restart my node so that the config.json should be recognized/running.

And when I am searching for transactions by address with the algod process, I am indeed using first and last parameter values.

I ran into the same issue. It might be because the lastRound parameter is above the current round number.