Next block consensus protocol not supported

Hi, while running goal version -v I get Build: 3.9.4.stable [rel/stable] (commit #921e8f6f).
The goal node status returns Last supported block (26075104) is committed. The next block consensus protocol is not supported. Catchup service is stopped..

Now… I’m running the updater in /my/node/data folder to align 3.13.2 release but it seems to be unable doing it. I tried also with the ./ -i -c stable -d /my/node/data command.

Any feed?

How did you install the node?
Using a Debian package or using the updater script?

In the former case, you may need to first upgrade the signing key following TestNet and MainNet Update: 3.12.2
and then:

sudo apt update
sudo apt upgrade

In the later case, can you show the error you got from ./

Also check repo and key.

curl -O
sudo apt-key add
sudo add-apt-repository "deb [arch=amd64] stable main"
sudo apt-get update

I’ve installed using Debian package. I followed the code under ( thanks for it @beaconet ) but it is still not working.

The ./ does not give any error :pensive:

Can you run:

which goal
which algod

to see which goal/algod you are using.

The script should not work if you use a Debian package.

Did you run sudo apt upgrade after the code by @beaconet ?

Yes. I’m really sorry, I was whatching the wrong terminal. I solved successfully upgrading the signing key. Thanks @fabrice and @beaconet !!! :pray:

1 Like