Version for `go-algorand`?

The repo specifies the version to be used can be found within go.mod – 1.14. I tried building with 1.14 but make test and make integration has failures. I also tried with 1.16.8 and make integration has failures.


  1. What version should I be using?
  2. If the integration tests are meant to fail because my environment is not set up properly, how can I set up my environment to make them work?

I intend on creating a PR to update any associated information so others can easily contribute, too. Thank you!

Which branch are you on?
It is best to be on rel/stable.

Did you follow the instructions there: GitHub - algorand/go-algorand: Algorand's official implementation in Go.
In particular, did you run?


and these scripts succeeded.

Which OS are you on?

I believe travis uses Go 1.14.7 (go-algorand/ at master · algorand/go-algorand · GitHub).
Travis scripts can be found there go-algorand/scripts/travis at master · algorand/go-algorand · GitHub and travis build passes.

Can you show the error you are encountering?

Which branch are you on?

I was previously using master because implied it was the appropriate branch to compare for a PR.

In particular, did you run [the shell scripts in initial environment setup]?

Yes and they succeeded.

Which OS are you on?

Ubuntu 20.04.3 LTS. I’ll try 18.04 in a virtualbox and post again since README indicates 18.04 might work, even though people in the Discord #general-dev said they contributed using 20.04 without failures in make test or make integration in the past.

With go v1.14.7 on rel/stable Ubuntu 20.04.3 LTS, make test runs without failures. Here’s make integration output (posting in case Ubuntu 20.04.3 LTS vs 18.04 doesn’t matter):

DONE 125 tests, 3 skipped, 18 failures in 630.467s
make: *** [Makefile:248: integration] Error 1

The messages in the failure cases indicate they’re caused by the node servers being unreachable.

Pastebin with full logs of make integration (notice iptables -nL lacks firewall configurations): (base) administrator@administrator-HP-Pavilion-Power-Laptop-15-cb0xx:~/Documents -