Algorand Follower node with docker

Hi Team,

I’m trying to setup an Algorand (Mainnet, Archival, Follower Node), as a prerequisite to setup Conduit and Indexer.
I’m using docker setup to start my node:

Image used: algorand/algod:latest
Command ran: docker run --rm -it
-p 4190:8080
-p 4191:7833
-e NETWORK=mainnet
-e TOKEN=aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa
-v ${PWD}/data:/algod/data/
–name mainnet-container

This generates the folder structure, within which I see a config.json, where I have added enabled the required properties of follower node (EnableFollowMode, MaxAcctLookback, CatchupParallelBlocks).

I’m running into this error:
DNS LookupSRV failed when using system resolver: no signature in DNS response for",“time”:“2024-01-16T11:44:20.719075Z”}
“got no relay DNS addrs for network mainnet”,“name”:“”,“time”:“2024-01-16T11:44:21.073624Z”}
“An issue occurred reading telemetry entry for ‘’: ReadFromBootstrap: DNS LookupSRV failed when using system resolver(no signature in DNS response for, fallback resolver(\u003cnil\u003e), as well as using default resolver due to no answer for (, 33) from DNS servers [
“It’s been too long since our ledger advanced; resyncing”,“name”:”“,“time”:“2024-01-16T11:44:31.258945Z”}
“Catchup Service: finished catching up, now at round 0 (previously 0). Total time catching up 184.073µs.”,“name”:”",“time”:“2024-01-16T11:44:31.259217Z”}

I have also enabled “Archival”: true, “EnableFollowMode”: true in the config.json
But error persists.

Please let me know how I can get my node to sync and if there is a snapshot available for the node to catch up to latest.