Error on catchup


When i am trying to catchup, its showing me the following error:
Cannot contact Algorand node: open /Users/zeeshanmazhar/node/datafastcatchup/algod.token: no such file or directory.

Is your node started?

You need to run goal node start first.

1 Like

I am running the node using ./goal node start -d data

if i run goal node start, it gives error:

error creating file for capturing stderr: open /var/lib/algorand/algod-err.log: no such file or directory

error creating file for capturing stdout: open /var/lib/algorand/algod-out.log: no such file or directory

Algorand node failed to start: node exited with an error code, check node.log for more details : exit status 1

when i run ./goal node status -d data it shows me this



goal node start -d data

all the goal commands requires the -d <data directory>; that allows you to have multiple networks running on the same host. ( i.e. betanet, testnet )

You are very close @zeeshanmazhar. Just have an issue with data directory and perhaps the catchpoint you are grabbing for the mainnet network.

We know this works:

./goal node status -d data

So, try this (for mainnet or adjust the first line for testnet | betanet):

% CATCHPOINT=$(curl$ALGORAND_NETWORK/latest.catchpoint)
% goal node catchup $CATCHPOINT -d data

I think node is syncing now

But as per the documentation when i run this command ./goal node status -d ~/node/datafastcatchup it gives error, please check the screenshot.

Yes, I now see our documentation uses -d ~/node/datafastcatchup rather than -d ~/node/data as found elsewhere. It’s important to ensure the -d </path/to/data_folder> matches for both the goal node start and goal node catchup commands. Starting a node at one folder and then asking to catchup in a different folder will have unintended results.

Yeah, i understand, so now my node is syncing. right?

I think alogrand should post some video tutorials for the setup and configurations.

From your latest screenshot, no, your node is not yet in sync. It was at round 759369. and mainnet is currently beyond 10362269 by now. When the node is in sync, the “Sync Time” will be 0.0 and the “Time since last block” value will be < 5 seconds.

I suggest you run that code block above to get a more recent catchpoint.

I think my is already syncing, should i shop the node and then run the codeblock ?

Yes, stop, start and then run the code block again.

I did, i think i should wait till it get synced.

Yup. That looks better. Notice it’s using a recent catchpoint. It should not be long now. It’s in the process of downloading the 1000 blocks that comprise that checkpoint, then will confirm the hash of that set, then proceed to pull all blocks from there.

Thank you, so after this i will be able to access the indexer, right?

Indexer is outside of the scope of this thread, so I’ll suggest you review the documentation provided below, then open a new thread with indexer specific questions. Please note: Indexer requires a connection to an archive node. This thread discussed using fast catchup, therefore an indexer cannot connect to this node, as it lacks all of the block data.

Here is a good visual showing the infrastructure connections between algod and algorand-indexer

Here is a good article discussing using Indexer:

More detailed documentation here:

Alright, thank you very much, i will look at indexer.