Error starting node on Ubuntu Subsystem for Windows

Hi everybody,
I’ve followed command by command the following instructions:;
to install Algorand on Ubuntu Subsystem for Windows.

It went all smooth until I have tried to start the node with:
goal node start -d data
because with
./goal node start -d data
it says
-bash: ./goal: No such file or directory

Anyway, running that command, instead of starting the node it says:
error creating file for capturing stderr: open data/algod-err.log: no such file or directory
error creating file for capturing stdout: open data/algod-out.log: no such file or directory
Algorand node failed to start: node exited before we could contact it

Even with sudo it says the same. How can it be fixed?

Caveat - I don’t use windows, but, can you try using a full path to the data directory in the command i.e. “goal node start -d /var/lib/algorand”.

Note - In the older style of shell script installs, the data directory is created beneath the algorand directory (/var/lib/algorand/data), in the newer apt packages style the default data directory is the same (/var/lib/algorand).

I’ve tried your command with all the paths you’ve mentioned, nothing worked.

I’ve even tried to create those two files in these paths. nothing.

I went ahead and ran through the install on a copy of Windows and it did work when I used both the full path and sudo to run the start command “sudo goal node start -d /var/lib/algorand”.

However, this has the consequence of creating all the ledger/log/algod files under root. I’m not sure if the Algorand team has a better suggestion for running under the Windows sub-system (@tsachi).

Depending on your needs @GGolov you might find the Docker sandbox project Algorand released to be superior or try running under a Vagrant VM.

Yep, I forget to try with sudo those commands. Thanks.

Our current priorities are around making a deployable(s) that works natively under Ubuntu 18, Ubuntu 16, Centos/Redhad 7-8, Raspabian/32 and MacOS.

We have not experimented with Ubuntu Subsystem for Windows yet. If you’d like to continue using Windows as you’re primary operating system, you could either -

  1. Use an Ubuntu Virtual Machine.
  2. Use a docker container.
  3. Try to follow @Tim notes above. It sounds like it should be “doable”, but I have yet to try it myself.

Good luck!