I want to get a transaction by txid,but get " failed retrieving information from the indexer "

I execute the following command:

curl -H “X-Algo-API-Token:$(cat ./data/algod.token)” ‘http://localhost:8080/v1/transaction/AMI2SDCTAMFFC546X2DQAWM5J624E4CUKMTEHCVVKS54EQURN6PQ

get this: failed retrieving information from the indexer

this is my algod configure(set Archival Mode,enable indexer):

node 's Last committed block is 95614

txid is AMI2SDCTAMFFC546X2DQAWM5J624E4CUKMTEHCVVKS54EQURN6PQ

found in algoexplore,so what’s wrong with it?

curl -H “X-Algo-API-Token:$(cat ./data/algod.token)” “http://localhost:8080/v1/transaction/AMI2SDCTAMFFC546X2DQAWM5J624E4CUKMTEHCVVKS54EQURN6PQ

Worked for me and I see the transaction. I also tested with API and it works. How big is the indexer.sqlite file in your data directory? After changing did you restart?

the question is solutioned,build index by indexer is slow .