Node has been running for 2 days

I had to reboot my pi 4b due to display was lost and wouldn’t come back up. now when i try to start the node I get this.
./goal node start -d data
Algorand node failed to start: node exited with an error code, check node.log for more details : exit status 2

I went to the node.log how do i jump to end on it. so i can read the log?

try tail -n 100 node.log to show the last 100 lines on the log file.

this is the end of my node.log
{“Context”:“Agreement”,“Hash”:“KYBONECTBPN2RJVJ3HE2VJLMEJRIQJOKIOCGXYD4FDH5KPFGETPQ”,“ObjectPeriod”:0,“ObjectRound”:0,“ObjectStep”:0,“Period”:0,“Round”:13409875,“Sender”:“3F3QL7IHS2D6LTPP2K6OG35DXW2GY7VNXLRM57PIHUMYHJKZGKGJ3MENAM”,“Step”:0,“Type”:“RoundStart”,“Weight”:0,“WeightTotal”:0,“file”:“actions.go”,“function”:“github.com/algorand/go-algorand/agreement.ensureAction.do",“level”:“info”,“line”:253,“msg”:"finished round 13409875”,“time”:“2021-04-24T09:44:54.307405-04:00”}

++++++++++++++++++++++++++++++++++++++++
Logging Starting
Telemetry Enabled: 96c5384a-77b4-435f-919e-9ba25f365553:Ansuz4u
Session: b0658e20-5175-4a8a-8f8e-de6da05ec4b0
++++++++++++++++++++++++++++++++++++++++

tail -n 100 algod-err.log
panic: runtime error: invalid memory address or nil pointer dereference
[signal SIGSEGV: segmentation violation code=0x1 addr=0x0 pc=0xb559d460]

goroutine 1 [running]:
runtime/internal/atomic.goLoad64(0x850712ac, 0x852618e4, 0x85071201)
runtime/internal/atomic/atomic_arm.go:131 +0x1c
github.com/algorand/go-algorand/crypto/merklearray.(*workerState).nextWorker(0x85071290, 0x8526190c)
github.com/algorand/go-algorand/crypto/merklearray/worker.go:90 +0x44
github.com/algorand/go-algorand/crypto/merklearray.Build(0xb680a3f8, 0x8976c580, 0x40, 0x0, 0x5f767a0)
github.com/algorand/go-algorand/crypto/merklearray/merkle.go:75 +0x158
github.com/algorand/go-algorand/data/bookkeeping.Block.TxnMerkleTree(...)
github.com/algorand/go-algorand/data/bookkeeping/txn_merkle.go:34
github.com/algorand/go-algorand/data/bookkeeping.Block.paysetCommit(0xcc9e54, 0x0, 0x90e60256, 0xa8db0b53, 0xc9d9a9a6, 0x226ca5aa, 0xca258862, 0xe06b8443, 0xd5cf287c, 0xdf24a63c, …)
github.com/algorand/go-algorand/data/bookkeeping/block.go:500 +0x154
github.com/algorand/go-algorand/data/bookkeeping.Block.PaysetCommit(0xcc9e54, 0x0, 0x90e60256, 0xa8db0b53, 0xc9d9a9a6, 0x226ca5aa, 0xca258862, 0xe06b8443, 0xd5cf287c, 0xdf24a63c, …)
github.com/algorand/go-algorand/data/bookkeeping/block.go:492 +0xac
github.com/algorand/go-algorand/data/bookkeeping.MakeBlock(0xcc9e53, 0x0, 0xadd3ee81, 0x2ee71957, 0xb7eaef9, 0xe59ab55c, 0x3744ff48, 0xc8fdfd18, 0xe1428d9a, 0xf42fe4e2, …)
github.com/algorand/go-algorand/data/bookkeeping/block.go:477 +0x3d0
github.com/algorand/go-algorand/data/pools.(*TransactionPool).recomputeBlockEvaluator(0x851be6c0, 0x852645d4, 0x0, 0x85196540, 0x59, 0x0, 0x0)
github.com/algorand/go-algorand/data/pools/transactionPool.go:666 +0x338
github.com/algorand/go-algorand/data/pools.MakeTransactionPool(0x8582a000, 0x0, 0x0, 0x4, 0x0, 0x0, 0xf8475800, 0xd, 0x0, 0x0, …)
github.com/algorand/go-algorand/data/pools/transactionPool.go:112 +0x250
github.com/algorand/go-algorand/node.MakeFull(0xb6818768, 0x850107d0, 0x8502b060, 0x12, 0x0, 0x0, 0x4, 0x0, 0x0, 0xf8475800, …)
github.com/algorand/go-algorand/node/node.go:208 +0xbe8
github.com/algorand/go-algorand/daemon/algod.(*Server).Initialize(0x85265db4, 0x0, 0x0, 0x4, 0x0, 0x0, 0xf8475800, 0xd, 0x0, 0x0, …)
github.com/algorand/go-algorand/daemon/algod/server.go:127 +0x5b4
main.main()
github.com/algorand/go-algorand/cmd/algod/main.go:292 +0xd8c

@Ansuz4u ,

Thanks for providing that info. This is a bug in the implementation that would affect all RasbPI machines. I will file an issue for that so that the algorand dev team could look at this.

edit: feel free to subscribe to algod panics on startup · Issue #2101 · algorand/go-algorand · GitHub so you can get a notification when this issue get resolved.

@tsachi
Do you have a time frame on the update being available to fix this issue? I would like to get my node back up and running.

The issue was already addressed on master, and was deployed yesterday to betanet ( BetaNet Update: 2.5.6 ).

I don’t have any particular date, but would expect it to reach mainnet shortly unless some regression would be found while it’s on betanet.

1 Like