Setting PW for Wallet Error -

Working with the Python SDK, I followed the standard startup procedure but am having an issue creating a wallet.

sudo ./sandbox up testnet (executed fine)
sudo ./sandbox status (gives a hash)

sudo ./sandbox goal wallet new Test

Please choose a password for wallet ‘Test’: Couldn’t read password: inappropriate ioctl for device

I don’t see a prompt or flag/command to set a PW? I don’t see docs for a kmd pw? Thanks in advance.

Welcome to Algorand!

I’ve just tried it on macOS and it works.
What is your OS?
If it is Windows, are you using Git Bash or WSL 2 with Ubuntu?
Can you check you have the latest sandbox software (git rev-parse HEAD)?

Also, it is strongly recommended not to use sudo with ./sandbox (or in general) as it can creates issues with permissions.
Is there a reason why you are using sudo?

I’m on Fedora 36.

I think most of the issues stemmed from me trying to run everything through the Pycharm IDE terminal and commands. It seemed to have lots of permissions issue.

When I run the sandbox through the main terminal I’m able to get it running (only with SUDO) and run Py scripts in the IDE successfully. Thank you for following up.

Screenshot from 2023-01-09 19-33-44

1 Like

Regarding the original issue.
Indeed the error inappropriate ioctl for device can stem from PyCharm not emulating a full terminal.
Here is a fix: python 3.x - I get 'Inappropriate ioctl for device' in PyCharm, but not the normal shell - Stack Overflow

Regarding the sudo comment.

Since you ran using sudo once, now you most likely made some files owner by root and you won’t be able to run without sudo.

But if you start from scratch, from a new freshly cloned sandbox folder, you should be able to run without sudo.
If not, please post here the error you see.