Testnet Algod API


Is there any public Algod API for Testnet? I found the API from AlgoExplorer, but it only supports the mainnet.

AlgoExplorer API supports mainnet, testnet and betanet, you need to change the root URL:

We are also supporting v2 and indexer APIs but in beta mode:
v1: https://api.algoexplorer.io/v2
Indexer: https://api.algoexplorer.io/idx2
v2: https://api.algoexplorer.io/v2

v1: https://api.algoexplorer.io/swagger.json
Indexer: https://api.algoexplorer.io/idx2/swagger.json
v2: https://api.algoexplorer.io/v2/swagger.json


Hi algoking,

Purestake’s API also supports mainnet, testnet and betanet, already updated for Algod and Indexer v2:

Signup: https://developer.purestake.io/

For Indexer:
V2: https://testnet-algorand.api.purestake.io/idx2
V1: https://testnet-algorand.api.purestake.io/idx1

For Algod:
V2: https://testnet-algorand.api.purestake.io/ps2
V1: https://testnet-algorand.api.purestake.io/ps1

You can change the “testnet” word for mainnet and betanet if needed.

In there Developer’s Portal you can find the documentation and some examples, as well as a link to a GitHub repo with examples (https://github.com/PureStake/api-examples).


Hi, I tried to get a transaction with txid by https://api.algoexplorer.io/idx2/transactions?txid=7MK6WLKFBPC323ATSEKNEKUTQZ23TCCM75SJNSFAHEM65GYJ5ANQ .

But got this response: {"error":"Request not found, please keep participating"}

Oh, I missed a /v2/ after the /idx2/. :sweat_smile: The right link is https://api.algoexplorer.io/idx2/v2/transactions?txid=7MK6WLKFBPC323ATSEKNEKUTQZ23TCCM75SJNSFAHEM65GYJ5ANQ

1 Like

Can’t open the page: https://developer.purestake.io/

It works now. it’s my networking issue :sweat_smile:.

Glad you got it working :slight_smile:

pleases, correct the link, for other users.

1 Like

Sure, corrected. Does these api have any rate limit?

Hi, @pipaman

When using this api https://api.algoexplorer.io/idx2/v2/accounts/OA22LGYZJKZVG2PZQKIMRQ26L7OBJFDUB6ZFOMVLRSZB7KLAYSNUOSWQDQ to get the information of an account, I got this error:

{"message":"failed while searching for account: account_round err pq: cannot cast type jsonb to bigint"}

Do you know how to solve this? Thanks.

We are looking for a solution to the issue, we are getting the same error hitting directly to the indexer locally.

1 Like

There was an error the first time I searched this on our own Indexer, but it cleared up on subsequent searches. There must be a bug in the Indexer Reader service itself.

1 Like

We are researching but so far it looks like something related to Postgres version and the indexer service itself.
But, we want to see if we can workaround the issue updating.

1 Like

Hi @Tim and @algoking ,

One of the issues is generated on this SQL sentence: SELECT (v -> 'account_round')::bigint as account_round FROM metastate WHERE k = 'state'

Saw similar issues in Postgres history for similar queries trying to extract a value from a stored json object.

For now, all indicates upgrading Postgres to latest version would solve it. We are working on it and expect to have news soon.