Algorand Indexer 2.6 / 2.7 Deprecation

To anyone using indexer versions older than 2.8.x: please start the upgrade to 2.8.x inclusive of the catchup process. Note that a rebuild of the indexer database is required, and will likely take over a week to complete for mainnet on most hardware specifications. See this prior announcement for catchup information and guidelines.

An upcoming consensus protocol upgrade next month will necessitate an indexer upgrade from 2.8.0, but will maintain compatibility with its database (greatly minimizing the time needed to complete the maintenance). There will not be an indexer release compatible with databases built against prior (< 2.8.0) versions of the indexer.

1 Like