Error getting suggested tx params "Missing Authentication Token"

Hi all,

Was using the EvanCoin example here Build your own coin on Algorand. Algorand 2.0 and the Algorand Standard… | by Evan Richard | Algorand | Medium with code here evancoin/main.go at master · EvanJRichard/evancoin · GitHub for creating a token. I have my unique purestake API token and updated the example code to direct towards the v2 testnet. Const mn and const ownerAddress have been checked and rechecked.

When I run it, I get

error getting suggested tx params: HTTP 403 Forbidden: {“message”:“Missing Authentication Token”}

Could you please specify the exact URL that you’ve used that end up generating the above error ?
( i.e. there could several reasons why you’ve received this error message; you haven’t provided much information about your environment, setup, etc. )

Sure thing, set the algodAddress to

I’m using an Algorand Studio workspace and docker container setup for ubuntu 20.04

the above is just the base address. I’m wondering what the full request URL looks like.
( including the full path ). If Algorand Studio doesn’t provide this option, I would try and install Wireshark and examine all the outgoing HTTP requests to see what request is being made ( it might be an overkill, there could be an internal Algorand Studio feature that would do that - but I’m unfamiliar with it… )

Downloaded wireshark. No idea how to use this.

Tried some of the capture options - got “Couldn’t run /usr/bin/dumpcap in child process: Permission denied” for a lot of them

Redid everything in GoLand, debugging log shows this…

GOROOT=/home/user/go/go1.17.6 #gosetup
GOPATH=/home/user/go #gosetup
/home/user/go/go1.17.6/bin/go build -o /tmp/GoLand/___1go_build_awesomeProject1 -gcflags all=-N -l awesomeProject1 #gosetup
/snap/goland/166/plugins/go/lib/dlv/linux/dlv --listen= --headless=true --api-version=2 --check-go-version=false --only-same-user=false exec /tmp/GoLand/___1go_build_awesomeProject1 –
API server listening at:
Error getting suggested tx params: HTTP 403: {“message”:“Forbidden”}

Can you show what the way you created your algod client in Go, replacing the token by xxx?
This error most likely comes from an incorrect URL or incorrect token.