Go Algo node on OSX / Apple Silicon

Hi, I’m trying to spin up a node on Mac OSX / Apple Silicon but get an error that is documented here:

Can anyone help me resolve the issue?
Thanks in anticipation

1 Like

If’s definitely buildable on M1s if you’re compiling it yourself (I closed that issue with the issue I finally found).
The amd64 version will also work as-is through the built-in emulation if you just use the update.sh installer script referenced in the node installation docs.

1 Like

Thanks Patrick - my frustration is that I follow the instructions on the portal / GitHub to the letter and a problem that was identified a long time ago still causes it to fail. To compound it, there is no step by step instruction on how to get it to work - just some fairly vague statement about it working through “built in emulation” as is. Well not for me clearly! Which update.sh are we talking about here - a link would be helpful. !n desperation I tried updating a couple of things - sodium etc but still no joy. If this was using some bleeding edge hardware I could maybe understand it but Apple Silicon when we’re approaching M4? Surely this should just work by now - especiially if we’re trying to reduce the friction of people onboarding to Algorand?

1 Like

Just following the standard installation instructions should work fine if you don’t want to build it yourself:

Thanks Patrick,
I’m determined to build it but am now getting:
The version of quic-go you’re using can’t be built on Go 1.21 yet

which seems strange as I’m on Go 1.22 and have the latest quic-go downloaded from GitHub.
I will keep at it…

the go.mod for go-algorand states 1.20 for the go version though.
You may explicitly need go 1.20 to avoid issues.

Thanks for your help Patrick - I really appreciate it.
I upgraded go to the latest as the go-pic documentation suggested that the error wouldn’t happen from go 1.22 onwards I think. Anyhow I’ve regressed Go version and am trying once more…

Yes running it with Go 1.20.14 works!
It’s a shame it doesn’t work with the latest version of Go but I suspect there must be a good reason.

1 Like