Period 6, voting session 1 - Can't vote using Pera Algo Wallet

Hi everyone,
I tried to finish voting in the current session. But when I hit the submit button, Peta wallet opens, but it shows the the overview page and not a transaction to submit my vote. Now I had the idea to do it by hand as I did in the very first voting session. But it seems to me that it is not possible to send a zero amount transaction.

My questions is now: How can I submit my vote?

Any feedback is welcome! Thanks in advance!


Make sure you have the latest version of Pera Wallet. And, disconnect it from the governance page and reconnect it. It will work.

Don’t try to vote manually; it’s a recipe for mistakes, e.g., accidentally sending actual ALGOs, etc.

1 Like

Thanks for that advice! Disconnecting is simple but I couldn’t figure out how to reconnect the wallet. Is any documentation out there how to do that or is it to simple and I just think a bit awkward?

In the end I succeeded. The trick that uncovered the “connect wallet” button was to click on my wallet address on the governors page. This how-to from from Pera wallet gave me the essential hint:

And then after reconnecting my wallet, the voting procedure worked just fine.