Rekeying not working for account which is part of multi-sig

I tried to rekey an account which is part of a multi-signature wallet using a nano X and the official android wallet.
However, after successfully rekeying (it shows up when connecting the ledger) the old key still works in MyAlgo wallet and pythonSDK… I have tried with an account which is not part of a multi-sig and there is no issue (MyAlgo wallet loads the wallet, but any transactions requested fail).

Can you reproduce the issue on TestNet and give the addresses of the affected accounts on TestNet?

Note that if you have a multisig address A that is 2 out of 3 of public keys B, C, and D.
Then rekeying B, C, or D has NO effect whatsoever on A.
A still require signatures from 2 of the 3 public keys B, C, and D.

You can however rekey A to any other address A’.
A’ may be another multisig address like 3 out of 4 public keys E, F, G, and H.
Or A’ may be a stateless contract account / logicsig.
Or A’ may just be a simple ED25519 public key.

Hi Fabrice,

Thanks but I cannot rekey on the testnet. The app requires real algos to rekey.

The account is a 2 signature multisig with a 2 signature threshold. It says the multisig is version 1.

These are the two addresses
this is the combined address:
and this was the rekey transaction:

(all addresses are public creator addresses)

I see.
So the issue is that the transaction


But this has NO effect on the combined address KLKLHRAT525BOEPR72XMBIPDK77AI52TF6QC5LGNV2J2J3SCUGKDJVLCX4.
Public keys in multisig are NOT affected by rekeying.

For details, see my first comment.

OK thanks, I will look into rekeying the multisig to a new multisig.