Where does "./sandbox goal clerk compile" execute?

I’m having trouble compiling “.teal” files using sandbox. The file definitely exists, and I can run other goal commands successfully, like “goal node status”.

I have tried moving the “.teal” file to the “data” folder but see the same error. Any suggestions?

1 Like

It executes inside the docker container of the sandbox.

You can use ./sandbox copy ... to copy files there.

1 Like

Hi fabrice… i was playing with creating dapp and it told me the same…

./sandbox goal app create --creator RYQ4ZBRZB3QECPWO44XSWOFWPMUOXLQHSBFMTM7MBTO2V4B47LF2SO4LSM --approval-prog approval_program.teal --clear-prog clear_state_program.teal --global-byteslices 0 --global-ints 1 --local-byteslices 0 --local-ints 0

approval_program.teal: open approval_program.teal: no such file or directory


./sandbox copy approval_program.teal
./sandbox copy clear_state_program.teal

did the thing…

perhaps someone should put it to the hello world app documentation

1 Like

Thank you, fabrice! That works perfectly!

I’ve made a PR: