Fast-catchup don't complete

Hi,
I am completely new to Algo, I was trying to do my first transaction using this example: Your first transaction - Algorand Developer Portal.
The problem is that the fast-catchup with catchpoint remains stuck at 0/1000.
I have tried many times to clone sandbox but I had the same problem every time.
I am using macOS.

What should I do?

Usual issues are:

  1. You are using a HDD or a slow SSD. You now need a fast SATA SSD or an NVMe SSD.
  2. You don’t have enough RAM: you need at least 4GB.
  3. You have some DNS issues (when this happens, the round will always stay at 0).
  4. You don’t have the latest version of the sandbox

Please follow instructions of Fast Catchup not working in Sandbox on Windows (Mainnet) - #2 by fabrice after checking the above.

Hi Fabrice,

I am having the same issue. Do you have any advice on how to solves the DNS issues? I am stuck at 0/1000 and 0% also. Everything else seems to be working fine, all updated versions etc. Would really appreciate if you could help.

Thanks!

Kane

@lawlesskane

I had this problem and for me the issue was that I had run a local sandbox and not run a clean before trying to run a testnet sandbox. You could try:

./sandbox down
./sandbox clean
./sandbox up testnet

Hi funk,

Thanks for your reply. I’ve tried this, unfortunately no luck. I think the issue is because my laptop is old, still has HDD. I tried disabling DNS security (seen in another post as a potential solution) but didn’t work either. Will buy a new laptop tomorrow!