"No wallets found." when cmd "goal account changeonlinestatus"

After addpartkey successfully, i execute the command “goal account changeonlinestatus” for online status from offline.
it return:
No wallets found. Create a new wallet with goal wallet new [wallet name].

the command executed in mainnet. it is ok in testnet.

1 Like

When you lists the wallets ( goal wallet list -d ~/node/data ) does the wallet show up in the list? When you list the accounts in the specific wallet ( goal account list -d ~/node/data -w yourwalletname ) does the account in the from field of the transaction show up?

root@servername:/var/lib/algorand/mainnet-v1.0# ll | grep part
-rw-r–r-- 1 root root 483328 Jun 30 08:57 7ZL4I4JYK…341122.342122.partkey
-rw-r–r-- 1 root root 4890624 Jul 1 13:16 7ZL4I4JYK…360250.361250.partkey

wallet list returns:
Wallet: wallet1 (default)
ID: b6a9b0a38473fe11…

goal account list -d /var/lib/algorand -w wallet1 returns:
[offline] first 7ZL4I4JYK… ??? microAlgos *Default

algo@servername:~ sudo goal account changeonlinestatus -a 7ZL4I4JYK... -o=1 -d /var/lib/algorand No wallets found. Create a new wallet with `goal wallet new [wallet name]` algo@servername:~

if no wallet, the partkey won’t create successfully, but my partkey was created successfully.

Are you trying to use the same wallet accross TestNet and MainNet? Does the 7ZL… account have algos on MainNet?

~/testnet is my testnet directory
/var/lib/algorand is my mainnet directory
i think it is not the same wallet.

2 yes, it has 19 algos

when i use -w to specify the wallet, it returns:

algo@servername:~ sudo goal account changeonlinestatus -a 7ZL4I4JYK… -o=1 -d /var/lib/algorand -w wallet1
Wallet ‘wallet1’ not found


one difference between maintest and testnet :
testnet directory has a kmd directory, but mainnet has none.

algo@servername:~$ ll ~/testnet/ | grep kmd

drwx------ 3 algo algo 4096 Jun 28 17:18 kmd-v0.5/

algo@servername:~$ ll /var/lib/algorand/ | grep kmd


Are you running both main net and test net on the same node at the same time? BTW run
ps aux | grep kmd
If that only returns the grep run
goal kmd start -d yourdatadirectory

Also post the output of ps aux | grep algod

The directory orgnization is terrible using the Debian Package.

/usr/bin/kmd -d /root/.algorand/mainnet-v1.0/kmd-v0.5
/usr/bin/kmd -d /home/algo/.algorand/mainnet-v1.0/kmd-v0.5

is the directory /root/.algorand/mainnet-v1.0/kmd-v0.5 auto created by sudo ?

Can you restart the node, and create a new wallet and addpartkey and changeonlinestatus — all without using sudo?

the default user is algorand, so the user named “algo” can not addpartkey.

I have solved the problem by 3 steps:
chown -R algo:algo /var/lib/algorand
use -k params and not use sudo in all goal commands
change user and group in the file /lib/systemd/system/algorand.service

The permissions in /var/lib/algorand on Ubuntu 18.04 were a bit messed up after installation for me too. Access was denied to the mainnet-v1.0 directory so I couldn’t properly save participation keys or bring the account online. Trying sudo created it’s own problems (couldn’t see the wallet), so there was nothing for it but to recursively chown /var/lib/algorand. My node is running and the account is participating.

I must say, as a beginner, that I was surprised at how quickly the system churns through rounds. I can see that keeping valid participation keys ahead of the rounds may be a challenge. Now I’m wondering what would be a reasonable participation range: 200, 2000, 5000? By the time I get back to the server in the morning, my three participation keys will be spent.

1 Like

Thanks Gary. We are looking at this issue. On the round range if you set it to like 3 million it should be able to participate for 5.5 - 6 months. You can use goal later to refresh the participation key as well.

Good suggestion. I’ve created a new participation key with a range of 3M and hooked it in, so I’ll just let it run. Thankfully it’s not Windows, so I expect it will just keep going. :slightly_smiling_face:

The only issue I have here is reliability of power (ironic since I work for a solar power generation company). We tend to get random flicks here on the grid, which is just a little annoying.

Thanks Gary. BTW I love Solar!!

Same issue here, thanks for the input

Solved using https://developer.algorand.org/docs/installing-other-linux-distros