Sandbox indexer setup

Maybe i’m doing something wrong, but after starting the Algorand Sandbox i’ve entered the algod docker image (with ‘./sandbox enter algod’) and changed the node to become an archival node in order to use the indexer service (did this by modifing the config.json file key “Archival: true”). After that i’ve run the ‘./sandbox down’ command and then started everything again with ‘./sandbox up’. Still can’t figure out why the indexer does not populate the db and thus i get no results when searching for a transaction.
Hope somebody can help me figuring out what my mistakes are!

That configuration is for Indexer V1. If you are trying to use V2 features that will require an additional download. Sandbox by default will install and run v2 indexer if you are using a private network with it, but not if you startup testnet. See this article on indexer changes. Algorand Developer Portal

Thank you for answering. I’ve set up the sandbox and launched it with the ‘sandnet’ so that i could start using the V2 indexer to try out its features. My problem is that after i made some transactions on the net (using the default accounts provided with the private network) the indexer does not find them despite i can see them using the goal tool. It seems that the new transactions are not added to the PostgreSQL DB. So my question is, does this default test environment use the indexer just in read-only mode? And if so, is it possible to change that setting?

Can you run ./sandbox test and also ./sandbox status?

I had the same problem and I solved it doing:

./sandbox up release


Thank you this solved my problem as well!

1 Like