While trying to participate in consensus: “Account was closed but still has a participation key active.”

Hello,

After generating my participation keys and sending a keyreg txn, I see this in my algod logs:

Account was closed but still has a participation key active.

The address is correct and I can query either algoexplorer or the local node and see that there is indeed a balance in it

Any ideas?

Let it run like that for a few hours, it will sort itself out. This happened to me when setting up on Oracle via d13’s guide. After a while, fixed itself.

Thank you for the help. It has been about 12 hours now and I am still getting the error message.

I will keep waiting to see if it resolves.

1 Like

Odd. Sorry to hear you’re continued troubles :frowning: I just set my first node up a few days ago and was having this issue, hoped I could help! xD There are a lot of knowledgeable people in this forum though, so I’m sure you’ll get an answer soon!

Any idea I can think of to try to debug this would most likely dox your address unfortunately…

Can you try to create a fresh new address with 1 Algo and see if you have the issue?

If you don’t have issues, I would compare the output of goal account listpartkeys for both addresses.

1 Like

Thank you for the help! When I run the goal account listpartkeys command, it shows that my keys are not registered.

Is there a way to force a registration?

Registration works by sending a key registration transaction using goal account changeonlinestatus.
Can you see the key registration in algoexplorer.io ?

Nope - there are no transactions on algoexplorer.io when I search by my wallet address. I thought the goal account addpartkey command would also register my wallet but maybe that is incorrect?

I tried to use the command
goal account changeonlinestatus -a [wallet address] -o and it said that no wallet could be found.

Now I am very confused - I have a wallet that I am trying to use, it has some algos in it, and I have algos staked with algofi vault.

I will log a support ticket to see if they can help and if not, then I will just start again from scratch.

There are two parts to participate:

  1. Create a participation key (goal account addpartkey)
  2. Register the participation key (goal account changeonlinestatus)

A few notes:
a. For the second part, you will need to sign the key registration transaction. This would depend on your setup. For example, this tutorial explains it in detail if you use a Ledger Nano X/S.
b. If you are using the AlgoFi vault and want to participate with that, you need to follow AlgoFi documentation to participate: Participating in Consensus - Algofi

1 Like

Thank you for the reply - I think I figured out what I was did wrong.

I originally generated the participation keys for my wallet, not the vault wallet that algofi uses on their platform.

To fix this, I sent a key reg offline transaction through algofi, then used the vault account address to create a new participation key (goal account addpartkey) and then used that info to send a new registration transaction through algofi.

goal account listpartkeys now shows that I am registered and I will monitor the node.log file to make sure I don’t have any errors.

Again - thank you for the help.

2 Likes