Command not found: goal

I am installing a node on a new machine and following the documentation for Install a Node. The installation sequence I followed was as follows.

export ALGORAND_DATA="$HOME/node/data"
export PATH="$HOME/node:$PATH"
mkdir ~/node
cd ~/node
curl -O
chmod 544
./ -i -c stable -p ~/node -d ~/node/data -n
RETURN: Current Version = 0
RETURN: This platform arm64 is not supported by updater.
goal node start
RETURN: zsh: command not found: goal
./goal node start
RETURN: zsh: no such file or directory: ./goal

I am not sure where the error is coming from. In my node directory, there are are only two files data and I think the problem is the export ALGORAND_DATA function is not exporting the necessary data, but I am not sure why. Any suggestions or advice would be greatly appreciated, thanks!

Somebody answered in Discord, but copying the answer there.
Since you’re on an Mac M1, you need to use Rosetta 2: How to run a node on MacOS Big Sur & M1? - #2 by fabrice

1 Like

I am still getting an error here. For Homebrew, running:

Command Line Input: arch -x86_64 /bin/bash -c "$(curl -fsSL []("

Returns: curl: (22) The requested URL returned error: 404

For the Node installation, running:

Command Line Input: arch -x86_64 /bin/bash -c "curl -O"

Returns: curl: (23) Failed writing body (0 != 853)

I got an error installing for both Homebrew and the Algorand Node. Running ls in the node directory yields two files: data and

However, the second option, installing the Rosetta-Terminal worked for Homebrew installation. But I am still getting the same error for the Algorand Node. Running:

Command Line Input: curl -O

Return: curl: (23) Failure writing output to destination

I have been iterating between installing in a virtual environment using Anaconda and running directly, however neither has returned a successful installation. I also was sure to follow the Install Instructions. I am running on macOS Big Sur 11.3.1.

Any suggestions or advice would be appreciated. Thank you!

It’s simpler to run the full Terminal under Rosetta. So you don’t have to add arch -x86_64 in front of everything.
Follow the steps “Create a separate Rosetta 2 Terminal” in Run x86 Terminal Apps (Like Homebrew) on Your New M1 Mac | by Ahad Sheriff | The Startup | Medium


curl -O

should be working.
It looks like there is an issue with your permission.
Can you run ls -lha?

1 Like

I ran:

curl -O

from my node and got:

curl: (23) Failed writing body (0 != 853)

But, running the same curl function from the command line, not in the node directory worked fine. Which, may be a problem because it would install software not in the node on my machine. So, I may uninstall that. I also ran ls -lha from the node and it returned:

total 40
drwxr-xr-x   4 fortiorb  staff   128B Jul  5 15:18 .
drwxr-xr-x+ 25 fortiorb  staff   800B Jul  7 14:15 ..
drwxr-xr-x   2 fortiorb  staff    64B Jul  5 15:18 data
-r-xr--r--   1 fortiorb  staff    17K Jul  5 15:18

Thanks for your time and help! It is greatly appreciated.

Yes, use another folder.
It looks like an issue with permission: does not have writing permissions.

1 Like