Zsh: command not found: goal

I am consistently getting this error trying to run goal. I have tried:

echo 'export PATH="/path/to/goal/directory:$PATH"' >> ~/.zshrc
source ~/.zshrc
goal version

But the error repeats.

zsh: command not found: goal

I had to remove my node a few months ago and now I want to reinstall, so I can submit TEAL code to the blockchain. I want the smaller form of the Node, but I am finding the node installation instructions unintelligible.

I am running on Mac with an Apple M1 Chip. What are the basic installation commands?

The purpose is to be able to run TEAL using the goal interface via the command line.


I also tried running:

nano ~/.zshrc

Adding a new path:

export PATH="$HOME/goal:$HOME/algorand:$PATH"

Revising and running.

source ~/.zshrc

goal version

But, I am getting the same shell error.

zsh: command not found: goal

I’m working with chatGPT to solve this. It seems this issue usually occurs when the Algorand binaries are not properly installed or the installation location is not added to the system’s PATH environment variable. But, there is no mechanism for properly installing Algorand binaries that I can find on the Algorand website. Any advice or suggestions would be greatly appreciated. Thanks!

but chatGPT has knowledge 2 years old… i recomenned to check out algokit Algorand Developer Portal and all the videos on their youtube channel on how to work with it…

Bard is live, maybe I will try that today instead. The problem is this is a specific error. It is not a bug covered in tutorials.