Help with running indexer

I was able to start and sync my node. Now i am stuck i have read the readme files I extracted the the source files v2.3.2 into my indexer file on my Raspberry pi. which of the indexer binaries do I download for use on my Pi?

update I got the bianaries downloaded but the node is running on my local machine what port should I use?

Default port is 8980.
See Algorand Developer Docs

what host name should I be using?

Default --server :8980, listen to all IPs.

--server localhost:8980 restricts to localhost, which is more secure

{“level”:“error”,“msg”:“could not init db, dial tcp [::1]:8980: connect: connection refused”,“time”:“2021-04-12T22:30:49-04:00”}

./algorand-indexer daemon -P “host=localhost port=8980 user=******* password=********* dbname=[ledgerdb] sslmode=disable” --algod=~home/pi/node

is the user name and pass word for my local machine?

There are multiple host and ports:

  • the host/port for algod --algod-net="http://[your-host]:[your-port]" ---algod-token="[your-api-token]" - you must have an algod server already running and specify the corresponding host/port
  • the host/port for the PostgreSQL db -P "host=[your-host] port=[your-port] user=[uname] password=[password] dbname=[ledgerdb] sslmode=disable" - you must have a PostgreSQL db running and specify the corresponding host/port
  • the host/port on which indexer listen to queries, that’s what I answered to you above --server

See Algorand Developer Docs

Your PostgreSQL db is not working properly (either not installed, not running or not using the correct port - 8980 is very unlikely for PostegreSQL and will conflict with algorand-indexer.

Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State
tcp 0 0 127.0.0.1:8080 0.0.0.0:* LISTEN
tcp 0 0 127.0.0.1:631 0.0.0.0:* LISTEN
tcp 0 0 127.0.0.1:5432 0.0.0.0:* LISTEN
tcp6 0 0 ::1:631 :::* LISTEN
tcp6 0 0 ::1:5432 :::* LISTEN
pi@raspberrypi:/ $
these are all my open ports

try -P “host=localhost port=5432 user=******* password=********* dbname=ledgerdb sslmode=disable”

If it does not work, please read the documentation of your postgresql install to get the correct connection string.

my issue my be postgresql isn’t started

I have my postgresql installed and fully set up.

I think you are correct, I will try this tonight its pointing at PostgreSQL.

i found my issue was my password had wildcards i removed them and the stated strings worked.