Indexer: "provided disabled parameter: note-prefix"

Hi everybody,
how can I enable parameter searching while querying Indexer? I’m searching with ( but it seems it has the note-prefix disabled.


Unfortunately you can’t enable it from the client side. Check out one of the other providers or run your own if this is a must have - Ecosystem Tools & Projects | Algorand Developer Portal

1 Like

another solution, if the project works on a subset of data, e.g., a single ASA or a small number of wallets, is to cache every transaction to a local database. Many projects need to monitor only a few main wallets, which will also contain the transactions of other wallets that have interacted

1 Like

I recommend trying other node providers AlgorandPublicData/public-indexer-providers.json at main · scholtz/AlgorandPublicData · GitHub

1 Like

as far as I know, all providers disable note-prefix, the option to disable this parameter was introduced quite recently in the Indexer probably because the performance impact is unacceptable in multi-user environment

Quicknode also offers an Algorand indexer, it’s the fastest I have tried to date

I was able to click out algod node on quicknode, but not indexer.

The endpoint was however user specific and not aplicable to enlist to public algorand data project.

I use Quicknode’s Indexer quite often, what problems did you experience?

I don’t see much difference with PureStake, for both there is no public end-point, you have to register an account and get an API KEY and a free basic plan, or a paid premium one.

where should I click in order to get the indexer? i can see i can get only the algod there…

Just replace algod with index (remove trailing slash for Python SDK) in the endpoint URL