Issue ASA problem - testnet - algob

Hi everyone, I’ve got a problem when I try to issue a permissioned token ASA on testnet following the guide algo-builder/examples/permissioned-token at master · scale-it/algo-builder · GitHub.

I created correctly smart contract, ASA and clawback lsig but I’ve got a problem when I try to run ISSUE operation to transfer ASA from reserve to receiver.

Here my information:

Owner / Issuer:



Controller APP ID:

Clawback lsig:

clawbackLsig : 
 LogicSigAccount {
  lsig: LogicSig {
    tag: Uint8Array(7) [...],
    logic: [...],
    args: [],
    sig: undefined,
    msig: undefined
  sigkey: undefined

When I try to run issue command with algob with algob run \scripts\admin\issue.js It returns me error

Transaction Failed Error: cannot POST /v2/transactions (400)
    at Response.toError (C:\Users\X\AppData\Roaming\nvm\v14.17.0\node_modules\@algo-builder\algob\node_modules\superagent\src\node\response.js:95:15)
    at Response._setStatusProperties (C:\Users\X\AppData\Roaming\nvm\v14.17.0\node_modules\@algo-builder\algob\node_modules\superagent\src\response-base.js:126:48)
    at new Response (C:\Users\X\AppData\Roaming\nvm\v14.17.0\node_modules\@algo-builder\algob\node_modules\superagent\src\node\response.js:41:8)
    at Request._emitResponse (C:\Users\X\AppData\Roaming\nvm\v14.17.0\node_modules\@algo-builder\algob\node_modules\superagent\src\node\index.js:928:20)
    at fn (C:\Users\X\AppData\Roaming\nvm\v14.17.0\node_modules\@algo-builder\algob\node_modules\superagent\src\node\index.js:1130:38)
    at IncomingMessage.<anonymous> (C:\Users\X\AppData\Roaming\nvm\v14.17.0\node_modules\@algo-builder\algob\node_modules\superagent\src\node\parsers\image.js:8:5)
    at IncomingMessage.emit (events.js:388:22)
    at IncomingMessage.emit (domain.js:470:12)
    at endReadableNT (internal/streams/readable.js:1336:12)
    at processTicksAndRejections (internal/process/task_queues.js:82:21) {
  status: 400,
  text: undefined,
  method: 'POST',
  path: '/v2/transactions'

Here my group trx (issuanceParams):

issuanceParams : [
    type: 6,
    sign: 0,
    fromAccount: {
      name: 'owner',
      sk: [Uint8Array]
    appID: 71196884,
    payFlags: { totalFee: 10000 },
    appArgs: [ 'str:issue' ],
    foreignAssets: [ 71192910 ]
    type: 4,
    sign: 1,
    assetID: 71192910,
    amount: 1,
    lsig: LogicSigAccount { lsig: [LogicSig], sigkey: undefined },
    payFlags: { totalFee: 10000 }

What am I missing?
Thank you

It looks like the node is misconfigured?

How did you configure the node in algob.config.js?
Did you use the default algo-builder/algob.config-template.js at master · scale-it/algo-builder · GitHub ?

If yes, did you run properly sandbox?
Is sandbox working?
What is the output of ./sandbox status?

If no, can you show your configuration (replacing tokens with stars)?

Hello, I’m not using sandbox, I tested with my archival local relay node and node too but without success!
Here my configuration algob.config.js

let defaultCfg = {

  host: "http://localhost",
  port: 54746,
  token: "X",
  accounts: accounts,
module.exports = {
  networks: {
    default: defaultCfg,

And I tried with node too

let defaultCfg = {
  host: "",
  port: "",
  token: {'X-API-Key': "Y"},
  accounts: accounts,

module.exports = {
  networks: {
    default: defaultCfg,

I don’t think node is the problem cause I deployed with success smart contract, and the ASA too.
Also the functions whitelist and opt-in are working good too!

Yes, I’m using the default algo-builder/algob.config-template.js at master · scale-it/algo-builder · GitHub.

I tried with default accounts or custom accounts too.

Error 400 should be malformed request, so I’m worried about issuance params!

So I’m not completely what is happening.

If you do not get a response here, you can try to ask on the algobuilder channel on Discord (Join the Official Algorand Discord Server!), which may be more active for algobuilder.

Thank you, I already posted on Discord channel too!
I’ll wait for a response, thank you again!

I’ve resolved changing SO, on Mac It’s working successfully!
I think the problem is with Windows SO, I don’t know why.