Minting ASA Error on

I tried several times to mint a new asset on, but I keep getting this error: “total asset issuance must be a positive number and smaller than 2^64-1” please how do I solve it.

Can you take a screenshot of the parameters you gave? What total asset issuance did you specify?

Oh yes, my bad, let me upload it. And I get the error when trying to mint 10,000,000,000 Ten billion. Funny enough 999,999,997 Million mints, this error occurs both in Mainnet and testnet. I believe its a bug, Any bug bounties? Smilling


Here is a reproduction of the parameters

There seems to be two things going on:

  1. assumes the total supply is of the unit with decimals. This means that when you set 10,000,000,000=10^10 and 6 decimals, it uses 10^16
  2. This should still be lower than 2^64-1. My guess is that the issue is with the fact JS only can safely represent integers up to 2^53-1

Yes, I believe so too, because after I tried to correct it, and I posted the error or issue here, I decided to switch to MyAlgo wallet to create my token, viola it created it with the same parameters with no error or issue. Thanks Fabrice. Grateful.

1 Like