Unable to withdraw funds from MyAlgo after integrating with Yieldly

I heard of Yieldly and wanted to give its lottery a try, but after a few rounds I decided to stop, withdraw my ALGO from my wallet and send it elsewhere. However, when I attempt to do this in MyAlgo I get the following error.

TransactionPool.Remember: transaction WRI5VILBCHAABITWPT3OXQ3SDG4I7A374NAH7Z73RUJASIVN6JGA: cannot close: 3 outstanding applications opted in. Please opt out or clear them

I believe this is due to my existing Yieldly smart contracts - algo staking, yieldly staking and bridge. I assumed Yieldly would have opted me out of these contracts once I removed my funds, but it seems like that’s not the case. I have removed my connection to Yieldly within MyAlgo but that didn’t clear these contracts, either.

I’ve tried reaching out to Yieldly across several channels and haven’t received a response in months. At this point, I’m assuming they’re just not going to help me.

I’m wondering if anyone in this forumn has experienced something similar, and if so are there any tips I could try to fix my situation?

Thanks in advance,

Sure, if you want to close fully the account you must close all live applications on it… The quick solution is to keep there the minimum and dont bother with app close.


(post deleted by author)

Fair enough, I suppose I can live with that. Thanks for your help, I just gave it a shot and it worked :+1:t3:

You can always manually send a “clear out” transaction to force opt out of an application.
This requires directly using the SDK or the command line and can have bad consequences in some cases.
For example, if you sent some Algos to an escrow and clear out the corresponding application, you will forever lose access to those Algos.