Trust Wallet not allowing Algorand spend

I have Bitcoin, Etherium, and Algorand in a multi-coin Trust software wallet on my iPhone. I’m able to spend Bitcoin and Etherium just fine, but not Algorand. I believe this has something to do with Algorand using something other than the BIP39 standard. The public Algorand blockchain shows my Algorand are still there under my address so that is fine, I just can’t access them with the private key known to the Trust app. Tried installing Trust wallet on a new iPhone and used my 12 word phrase to recover. Bitcoin and Etherium showed up just fine and are fully function for send/receive, but a zero balance showed for Algorand, even though the transaction history of my deposits were all there. I think the solution may be to convert my BIP39 12 word phrase to something the Algorand blockchain accepts and to start using the Algorand wallet since it uses a non-standard private key. Has anyone else run into this? Thanks!

I went to their web site : and there is no mention that Algo is supported. Is that a new capability ?

Edit: ok, I found it - it’s abit hidden inside their staking page.

As for the OP question - i’m not sure how to convert the address. You might want to ping their technical support / forum.

Have you tried How to recover my wallet with 24 word mnemonic - #6 by fabrice ?

Thanks Tsachi. I have been in touch with Trust Wallet support, providing them with lot’s of information and screen shots from my iPhone. They stopped responding when it became apparent it is not user error, but more likely a bug in their multi-coin wallet technology. I was able to send Algorand to a friend from my Trust Wallet on my iPhone a few months ago and haven’t used it since, so I’m thinking some upgrade caused the problem. Hopefully their silence means they’re quietly fixing the issue and will have an update out which rescues my Algorand funds. My funds still exist under my public address on the Algorand blockchain, so that gives me some hope.

Thanks Fabrice but I don’t think that will work since the Trust Wallet app uses only a 12 word recovery phrase.

The above response should also work for 12-word mnemonics.

Disclaimer : Typing passphrases and private keys on a computer may open you to attacks that are not possible on the Coinomi hardware. Algorand makes no representations regarding the functioning or security of third party wallets, exchanges, or tools mentioned in the answer above, and disclaims any liability therefor. You are fully responsible for the security and the availability of your keys.

Thanks Fabrice I downloaded the standalone HTML code for the Mnemonic Code Conversion tool and I’ll give that a try in the next few days with an old computer I have in storage which I never connect to the Internet.

Ok I gave it a try, but I don’t see how to get a 25 word Algorand-compatible phrase from it. The Mnemonic Code Converter accepted my 12 word phrase just fine (passing the validation) and generated both a BIP39 Seed and a BIP32 Root Key, but I don’t see any 25 word Algorand-compatible pass phrase output anywhere. I did choose Algorand for the coin option. There’s a bunch of stuff under, “Derivation Path”, including Account Extended Private Key and Account Extended Public Key, but no 25 word phrase outputs. There are also tabs for BIP32, BIP44, BIP49, BIP84, and BIP141.

Is there anyway I can use the BIP39 Seed value or the BIP32 Root Key I’m given with the Algorand iPhone app to restore my account? Doesn’t seem to be an option for either of those in the Algorand iPhone app.

Ok problem solved. Turns out my iPhone was not auto-updating the Trust app for some reason. I ran a manual update from the App Store and everything is working fine now. Would be good to have some sort of in-app notification when their app is out of date, especially when there’s no clear error message - only odd behavior suggesting you have lost funds. I’ll likely be migrating to the Algorand wallet app very soon. Thanks for all your efforts in trying to help!